zoukankan      html  css  js  c++  java
  • HDU acm 1003 Max Sum || 动态规划求最大子序列和详解

    Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 164592    Accepted Submission(s): 38540

     Problem Description

    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     

    Sample Input

    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     

    Sample Output

    Case 1:
    14 1 4
     
    Case 2:
    7 1 6
    #include<iostream>
    using namespace std;
    int main()
    {
        int T;//T为输入例子的个数 
        cin>>T;
        for(int i=1;i<=T;i++)
        {
            int N;//N为每个例子中数字的个数 
            cin>>N;
            int s=0,start1=1,start2,end,maxsum=INT_MIN;
            //s为以目前为止的点作为结束的一类中,最大的和 ;
    //start1为以目前为止的点作为结束的一类中最大和序列的起点坐标
    //start2为最终确定的最大和序列中的起点坐标
    //end为最终确定的最大和序列结束点的坐标
    //maxsum为最终确定的最大和 for(int j=1;j<=N;j++) { int a; cin>>a; if(s<0) { s=a; start1=j; } else { s+=a; } if(s>maxsum) { maxsum=s; start2=start1; end=j; } } cout<<"Case "<<i<<":"<<endl; cout<<maxsum<<" "<<start2<<" "<<end<<endl; if(i<T) cout<<endl; } }

    具体原理可参考http://alorry.blog.163.com/blog/static/6472570820123801223397/

     
  • 相关阅读:
    H53D旋转-遁地龙卷风
    Linux(CentOS 7)+ Nginx(1.10.2)+ Mysql(5.7.16)+ PHP(7.0.12)完整环境搭建
    CentOS 普通用户设置sudo权限
    CentOS 7 终端设置屏幕分辨率
    JavaScript 数组详解
    javascript 创建对象及对象原型链属性介绍
    Mac OS + Nginx + Mysql + PHP 本地环境搭建
    CocoaPods安装和使用教程
    Linux 下常用的压缩,解压方法
    启动 mysql 失败 Warning:The /usr/local/mysql/data directory is not owned by the 'mysql' or '_mysql'
  • 原文地址:https://www.cnblogs.com/denghui666/p/7157457.html
Copyright © 2011-2022 走看看