zoukankan      html  css  js  c++  java
  • ZOJ 1002 Fire Net (火力网)

    ime Limit: 1 Second    Memory Limit: 32768 KB

    Background

    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

    figure1

    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Input

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

    Output

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Sample input

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0

    Sample output

    5
    1
    5
    2
    4

    Analysis

    这道题数据量非常小,一共只有16个方格,因此用暴力搜索就可以了。在一个格子里放入Castle后要把它上下左右四个方向可以通达的所有格子进行标记,后面就不能再在这些格子里放入Castle了。

    Solution

    #include <iostream>
    #include <vector>
    using namespace std;
    
    int nResult = 0;
    void DoWork(int nOrder, char *pMat, int nBegin)
    {
    	vector<int> vecChanged;
    	int nSquare = nOrder * nOrder, nCastleCnt = 0;
    	for (; nBegin < nSquare; ++nBegin) {
    		if (pMat[nBegin] == '.') {
    			++nCastleCnt;
    			pMat[nBegin] = 'O';
    			vecChanged.clear();
    			int nCol = nBegin % nOrder, nRow = nBegin / nOrder;
    			for (int i = nRow - 1; pMat[i * nOrder + nCol] != 'X' &&
    				i >= 0; --i) if (pMat[i * nOrder + nCol] == '.')
    				vecChanged.push_back(i * nOrder + nCol);
    			for (int i = nRow + 1; pMat[i * nOrder + nCol] != 'X' &&
    				i < nOrder; ++i) if (pMat[i * nOrder + nCol] == '.')
    				vecChanged.push_back(i * nOrder + nCol);
    			for (int j = nCol - 1; pMat[nRow * nOrder + j] != 'X' &&
    				j >= 0; --j) if (pMat[nRow * nOrder + j] == '.')
    				vecChanged.push_back(nRow * nOrder + j);
    			for (int j = nCol + 1; pMat[nRow * nOrder + j] != 'X' &&
    				j < nOrder; ++j) if (pMat[nRow * nOrder + j] == '.')
    				vecChanged.push_back(nRow * nOrder + j);
    			for (vector<int>::iterator i = vecChanged.begin();
    				i < vecChanged.end(); ++i) pMat[*i] = 'H';
    				DoWork(nOrder, pMat, nBegin + 1);
    			for (vector<int>::iterator i = vecChanged.begin();
    				i != vecChanged.end(); ++i) pMat[*i] = '.';
    				pMat[nBegin] = '.';
    		}
    	}
    	if (0 == nCastleCnt) {
    		int nCnt = 0;
    		for (int i = 0; i < nSquare; ++i) nCnt += (pMat[i] == 'O');
    		if (nCnt > nResult) nResult = nCnt;
    	}
    }
    
    int main(void)
    {
    	vector<int> vecResult;
    	for (; ;)
    	{
    		int nOrder;
    		cin >> nOrder;
    		if (0 == nOrder) break;
    		int nSquare = nOrder * nOrder;
    		char *pMat = new char[nSquare + 4];
    		for (int i = 0; i < nOrder; ++i) cin >> (pMat + i * nOrder);
    		nResult = 0;
    		DoWork(nOrder, pMat, 0);
    		vecResult.push_back(nResult);
    		delete []pMat;
    	}
    	for (vector<int>::iterator i = vecResult.begin();
    		i != vecResult.end(); ++i) cout << *i << endl;
    		return 0;
    }
    



    知识共享许可协议 作者:王雨濛;新浪微博:@吉祥村码农;来源:《程序控》博客 -- http://www.cnblogs.com/devymex/
    此文章版权归作者所有(有特别声明的除外),转载必须注明作者及来源。您不能用于商业目的也不能修改原文内容。
  • 相关阅读:
    面经 收藏的 这可能不只是一篇面经
    2017网易秋招编程集合
    网易2017春招笔试真题编程题集合题解
    小朋友 排序
    网易编程题目 02 赶去公司
    网易有道2017内推选择题
    12,享元模式(Flyweight Pattern)是以共享的方式高效的支持大量的细粒度的对象。
    11,外观模式(Facade Pattern)是为子系统中的一组接口提供一个一致的界面,此模式定义了一个高层接口,这个接口使得这一子系统更加容易使用。
    新手进行Oracle MIS系统开发的步骤
    Oracle常用查看表结构命令(一)
  • 原文地址:https://www.cnblogs.com/devymex/p/1794662.html
Copyright © 2011-2022 走看看