zoukankan      html  css  js  c++  java
  • UVa OJ 120 Stacks of Flapjacks (烙饼叠)

    Time limit: 3.000 seconds
    限时:3.000秒

    Background
    背景

    Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.
    栈和队列常常被视为数据结构中的面包和黄油,广泛应用在体系结构、分析、操作系统和离散事件等领域。栈同时也在形式语言理论中发挥着重要的作用。

    This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.
    这个问题是让一个挑剔的厨师按照独特而完备的一组规则翻动煎饼,以保持煎饼(而不是面包)中的黄油和营养素不被烧坏。(这句话实在不知道怎么翻译才好,还望各位老师指正!Ps. 这道题翻译的难度要比解题大多了!!)

    The Problem
    问题

    Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.
    给定一叠煎饼,你要写一个程序计算出如何才能使这叠煎饼自底向上由大至小的排列。给定煎饼的半径作为其尺寸,一叠煎饼的大小各不相同。

    Sorting a stack is done by a sequence of pancake "flips". A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.
    为煎饼叠排序是通过一些列的“翻转”动作来完成的。一个翻转动作就是将一个小铲插到煎饼叠中的某两个煎饼之间,然后将小铲上面的所有煎饼翻转(倒转小铲上面的子栈)。每个翻转动作由其开始的位置给出,即小铲上面子栈中最底下一个煎饼的编号。整叠煎饼中最下面一个的位置为1,n个煎饼的叠中最上面一个的位置为n。

    A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.
    个煎饼叠由一组表示其中各煎饼直径的数构成,它们排列的顺序就是给出的这些数的顺序。

    For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):
    比如下面三个煎饼叠(煎饼8是左边一叠的最上面的一个)

             8           7           2
             4           6           5
             6           4           8
             7           8           4
             5           5           6
             2           2           7

    The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).
    左边一叠可以通过翻转第3个煎饼变成中间一叠的顺序。中间一叠可以通过翻转第1个煎饼变成右边一叠的顺序。

    The Input
    输入

    The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.
    输入包括一系列煎饼叠。每叠都由1到30个煎饼组成,并且每个煎饼的直径都在 1到100之间。输入由EOF结束。每叠煎饼独占一行,最上面的在行首,最下面的在行尾,各煎饼中间由空格隔开。

    The Output
    输出

    For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.
    对应于每叠煎饼数据,必须在第一行输出原叠的内容,接下来输出一组翻转动作的序列,使得这一叠煎饼自底向上由大至小的排列。输出的每一组翻转动作序列都要由0来结束(表示不再进行翻转)。一旦一叠煎饼已经排好序,就不能再进行任何翻转。

    Sample Input
    输入示例

    1 2 3 4 5
    5 4 3 2 1
    5 1 2 3 4

    Sample Output
    输出示例

    1 2 3 4 5
    0
    5 4 3 2 1
    1 0
    5 1 2 3 4
    1 2 0

    Analysis
    分析

    算法很简单,给你一组煎饼,用笔在纸上一画就知道该怎么办了。还是动态规划的思想,从底至上,保持已经遍例过的煎饼都是最大且有序的。比如输入的数据为:

    2 4 1 3 5

    按题目要求,4在顶5在底。5已经是最大的了,则移动到上一个煎饼3。3之上(含)最大的是4,先将4翻转到最顶,形成:

    4 2 1 3 5

    然后将4到3的子叠翻转,形成:

    3 1 2 4 5

    移动到上一个煎饼2,2之上(含)最大的是3,而3就在顶部,因此直接将2到3翻转,形成:

    2 1 3 4 5

    最后将2和1翻转,就完成了。注意:一定不要忘了在输入的一行数据下再将原数据复制输出一行,漏掉必然WA。按照上面的算法来做就不会出现多余的翻转操作,因此不用担心。

    Solution
    解答

    #include <algorithm>
    #include <iostream>
    #include <iterator>
    #include <deque>
    #include <string>
    #include <sstream>
    using namespace std;
    //主函数
    int main(void) {
    	//循环处理输入的每组字符串。每次循环一轮要输出最后的0和换行
    	for (string strLine; getline(cin, strLine); cout << '0' << endl) {
    		//按要求回应输入的字符串行
    		cout << strLine << endl;
    		//构造字符串流,以遍转换为数字
    		istringstream iss(strLine);
    		//将字符串转为数字,逆序(最底的在最前)存储在Stack里
    		deque<int> Stack;
    		for (int nDiam; iss >> nDiam; Stack.push_front(nDiam));
    		//从底依次上向进行翻转,保持i上面的都比i小
    		for (deque<int>::iterator i = Stack.begin(); i != Stack.end(); ++i) {
    			//找出i上面(包括i)的最大元素
    			deque<int>::iterator iMax = max_element(i, Stack.end());
    			//如果最大元素就是i则继续(将i指向上面一个)
    			if (iMax != i) { //否则要进行需翻转操作
    				//如果最大的不在最上面,则需先翻转到最上面
    				if (iMax != Stack.end() - 1) {
    					reverse(iMax, Stack.end());
    					//输出翻转的起点
    					cout << distance(Stack.begin(), iMax) + 1 << ' ';
    				}
    				//将最大的从最上面翻转到i的位置上
    				reverse(i, Stack.end());
    				//输出翻转的起点
    				cout << distance(Stack.begin(), i) + 1 << ' ';
    			}
    		}
    	}
    	return 0;
    }
    



    知识共享许可协议 作者:王雨濛;新浪微博:@吉祥村码农;来源:《程序控》博客 -- http://www.cnblogs.com/devymex/
    此文章版权归作者所有(有特别声明的除外),转载必须注明作者及来源。您不能用于商业目的也不能修改原文内容。
  • 相关阅读:
    SpringMVC案例3----spring3.0项目拦截器、ajax、文件上传应用
    TCP/IP、UDP、 Http、Socket的差别
    HttpClient 图讲解明
    数据库设计--数据的垂直拆分
    未经处理的异常在 System.Data.dll 中发生。其它信息:在应使用条件的上下文(在 &#39;***&#39; 附近)中指定了非布尔类型的表达式。
    VMware 下扩展linux硬盘空间
    cocos2d_android 第一个游戏
    解决安卓程序安装没图标的问题
    Qt编译错误GL/gl.h: No such file or directory
    【编程题目】二元树的深度
  • 原文地址:https://www.cnblogs.com/devymex/p/1799844.html
Copyright © 2011-2022 走看看