zoukankan      html  css  js  c++  java
  • POJ 1651

    题目链接:http://poj.org/problem?id=1651

    Time Limit: 1000MS Memory Limit: 65536K

    Description

    The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

    The goal is to take cards in such order as to minimize the total number of scored points. 

    For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
    10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

    If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
    1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

    Input

    The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

    Output

    Output must contain a single integer - the minimal score.

    Sample Input

    6
    10 1 50 50 20 5
    

    Sample Output

    3650

    题意:

    给出n个数字,每次能取出第i个数(1<i<n),score += num[i-1]*num[i]*num[i+1],如此不规定顺序的反复取出,直到最后只剩下两个数字;

    求最小的score为多少。

    题解:

    dp[1][n]表示答案,dp[i][j]=min( dp[i][j] , dp[i][k]+dp[k][j]+num[i]*num[k]*num[j] );

    AC代码:

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int INF = 0x3f3f3f3f;
    int n,num[105];
    int dp[105][105];
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++) cin>>num[i];
    
        memset(dp,INF,sizeof(dp));
        for(int i=1;i<n;i++) dp[i][i+1]=0;
    
        for(int len=3;len<=n;len++)
        {
            for(int i=1,j=i+len-1;j<=n;i++,j=i+len-1)
            {
                for(int k=i;k<=j;k++)
                    dp[i][j]=min( dp[i][j] , dp[i][k]+dp[k][j]+num[i]*num[k]*num[j] );
            }
        }
    
        cout<<dp[1][n]<<endl;
    }

    Description

    The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

    The goal is to take cards in such order as to minimize the total number of scored points. 

    For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
    10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

    If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
    1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

    Input

    The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

    Output

    Output must contain a single integer - the minimal score.

    Sample Input

    6
    10 1 50 50 20 5
    

    Sample Output

    3650
  • 相关阅读:
    jenkins 简单实现php集成上线部署
    关于PHP7
    关于版本迭代的那些事
    confirmit中手机端不能直接给input设置disabled属性
    confirmit中Html Styles有一处bug(或者说是一个坑)
    vsCode快捷键大全
    vscode打不开文件夹或文件夹未响应
    js中排序方法sort() 和 reverse()
    js最简单的编写地点
    js对象转换为json格式时,js对象属性中有值为null和undefined注意事项
  • 原文地址:https://www.cnblogs.com/dilthey/p/7892229.html
Copyright © 2011-2022 走看看