zoukankan      html  css  js  c++  java
  • POJ 1651

    题目链接:http://poj.org/problem?id=1651

    Time Limit: 1000MS Memory Limit: 65536K

    Description

    The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

    The goal is to take cards in such order as to minimize the total number of scored points. 

    For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
    10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

    If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
    1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

    Input

    The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

    Output

    Output must contain a single integer - the minimal score.

    Sample Input

    6
    10 1 50 50 20 5
    

    Sample Output

    3650

    题意:

    给出n个数字,每次能取出第i个数(1<i<n),score += num[i-1]*num[i]*num[i+1],如此不规定顺序的反复取出,直到最后只剩下两个数字;

    求最小的score为多少。

    题解:

    dp[1][n]表示答案,dp[i][j]=min( dp[i][j] , dp[i][k]+dp[k][j]+num[i]*num[k]*num[j] );

    AC代码:

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int INF = 0x3f3f3f3f;
    int n,num[105];
    int dp[105][105];
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++) cin>>num[i];
    
        memset(dp,INF,sizeof(dp));
        for(int i=1;i<n;i++) dp[i][i+1]=0;
    
        for(int len=3;len<=n;len++)
        {
            for(int i=1,j=i+len-1;j<=n;i++,j=i+len-1)
            {
                for(int k=i;k<=j;k++)
                    dp[i][j]=min( dp[i][j] , dp[i][k]+dp[k][j]+num[i]*num[k]*num[j] );
            }
        }
    
        cout<<dp[1][n]<<endl;
    }

    Description

    The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

    The goal is to take cards in such order as to minimize the total number of scored points. 

    For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
    10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

    If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
    1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

    Input

    The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

    Output

    Output must contain a single integer - the minimal score.

    Sample Input

    6
    10 1 50 50 20 5
    

    Sample Output

    3650
  • 相关阅读:
    eclipse 注释模板
    解决win7访问不了局域网共享文件
    java 执行command
    解决Unable to reach a settlement: [diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha1] and [curve25519-sha256@li
    解决java.lang.UnsupportedClassVersionError
    hadoop命令备忘
    intellij 提交代码到git
    java用代理访问
    解决 jersey javax.ws.rs.core.UriBuilder.fromUri(UriBuilder.java:119)
    解决Unable to locate Kerberos realm
  • 原文地址:https://www.cnblogs.com/dilthey/p/7892229.html
Copyright © 2011-2022 走看看