zoukankan      html  css  js  c++  java
  • Danganronpa 水题。

    Danganronpa

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 304    Accepted Submission(s): 217


    Problem Description
    Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of n kinds with a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this:

    1. Each table will be prepared for a mysterious gift and an ordinary gift.

    2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

    3. There are no limits for the mysterious gift.

    4. The gift must be placed continuously.

    She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?
     
    Input
    The first line of input contains an integer T(T10) indicating the number of test cases.

    Each case contains one integer n. The next line contains n (1n10) numbers: a1,a2,...,an(1ai100000).
     
    Output
    For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.
     
    Sample Input
    1 2 3 2
     
    Sample Output
    Case #1: 2
     
    Author
    UESTC
     
    Source
     

    比赛的时候水了一下, 就少了sum = 1的情况WA了。

    代码:

    #include<stdio.h>
    #include<string.h>
    #define N 110000

    int main(void)
    {
    int sum, i, j, t, n;
    int a[N];
    j = 0;
    scanf("%d", &t);
    while(t--)
    {
    j++;
    sum = 0;
    scanf("%d", &n);

    for(i = 0; i < n; i++)
    {
    scanf("%d", &a[i]);
    sum += a[i];

    }

    if(sum == 1)
    printf("Case #%d: 1 ", j);
    else
    printf("Case #%d: %d ", j, sum / 2);
    }


    }

    Recommend
    wange2014   |   We have carefully selected several similar problems for you:  5842 5841 5840 5839 5838 
  • 相关阅读:
    【转】SpringCloud学习
    Springboot中配置druid
    阿里云sql监控配置-druid
    Linux中Java开发常用的软件总结:
    java 搞笑注释
    Python之路-pandas包的详解与使用
    Python之路-numpy模块
    Python之路-Python中的线程与进程
    Python之路-Python常用模块-time模块
    Python之路-Python中文件和异常
  • 原文地址:https://www.cnblogs.com/dll6/p/5771842.html
Copyright © 2011-2022 走看看