zoukankan      html  css  js  c++  java
  • HDU 2955 Robberies

    J - Robberies
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

    Description

    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

    Input

    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

    Output

    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

    Notes and Constraints 
    0 < T <= 100 
    0.0 <= P <= 1.0 
    0 < N <= 100 
    0 < Mj <= 100 
    0.0 <= Pj <= 1.0 
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

    Sample Input

    3
    0.04 3
    1 0.02
    2 0.03
    3 0.05
    0.06 3
    2 0.03
    2 0.03
    3 0.05
    0.10 3
    1 0.03
    2 0.02
    3 0.05

    Sample Output

    2
    4
    6


    思路:将被逮到的概率转换成安全概率, 计算物品总价值,在获取不同物品价值时所能达到的最大安全概率。


    代码:

    #include<stdio.h>
    #include<string.h>
    #define max(a, b)(a > b ? a : b)
    #define N 210000

    double d[N];
    double w[N];
    int v[N];

    int main(void)
    {
    int i, j, t, n, sum;
    double p;

    scanf("%d", &t);

    while(t--)
    {
    memset(d, 0, sizeof(d));
    scanf("%lf %d", &p, &n);

    p = 1 - p;//安全的最大概率。
    sum = 0;

    for(i = 0; i < n; i++)
    {
    scanf("%d%lf", &v[i], &w[i]);
    w[i] = 1 - w[i];
    sum += v[i];
    }
    d[0] = 1;
    for(i = 0; i < n; i++)
    for(j = sum; j >= v[i]; j--)
    d[j] = max(d[j], d[j-v[i]]*w[i]);//在获取物品价值为j时所能达到的最大安全概率。

    for(i = sum; i >= 0; i--)
    if(d[i] - p > 0.0000000001)
    {
    printf("%d ", i);
    break;
    }

    }

    return 0;
    }

  • 相关阅读:
    Django Rest Framework 视图和路由
    DRF 权限 频率
    DRF 版本 认证
    Serializers 序列化组件
    学DRF之前
    RESTful
    windows下vmware配置nat网络
    python之路——网络编程
    图片上传
    数据库基本设计规范:
  • 原文地址:https://www.cnblogs.com/dll6/p/5775252.html
Copyright © 2011-2022 走看看