zoukankan      html  css  js  c++  java
  • POJ 2236 Wireless Network

    Wireless Network
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 12151   Accepted: 5129

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
    1. "O p" (1 <= p <= N), which means repairing computer p.
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

    The input will not exceed 300000 lines.

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS
    代码如下:
    /*
    解题思路:
    	并查集的简单应用,对每次修好的电脑对其它已经修好的电脑遍历,
    	如果距离小于等于最大通信距离就将他们合并。之后判断2台电脑是不是一个集合中就KO了
    */
    /*代码一:自己的代码
    #include<iostream>
    #include<cstring>
    #include<cmath>
    
    int point[1002][2],root[1002];
    bool dis[1002][1002],work[1002];
    int cal(int x1,int y1,int x2,int y2)
    {
    	return (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
    }
    
    int find_root(int i)
    {
    	while(root[i]>0)
    		i=root[i];
    	return i;
    	//return root[i]<0?i:find_root(root[i]);
    
    }
    
    void merge(int i,int j)
    {
    	i=find_root(i);
    	j=find_root(j);
    	if(i!=j)
    	{
    		if(root[i]<root[j])//此时root[i]的绝对值比root[j]大
    		{
    			root[i]+=root[j];
    			root[j]=i;
    		}
    		else
    		{
    			root[j]+=root[i];
    			root[i]=j;
    		}
    	}
    }
    
    int main()
    {
    	using namespace std;
    	int n,i,j,a,b,d;
    	char s;
    	while(cin>>n>>d)
    	{
    		memset(work,false,sizeof(work));
    		memset(root,-1,sizeof(root));
    		for(i=1;i<=n;++i)
    			cin>>point[i][0]>>point[i][1];
    		for(i=1;i<=n;++i)
    			for(j=1;j<=i;++j)
    			{
    				int t=cal(point[i][0],point[i][1],point[j][0],point[j][1]);
    				if(t<=d*d)
    					dis[i][j]=dis[j][i]=true;
    				else
    					dis[i][j]=dis[j][i]=false;
    			}
    		while(cin>>s)
    		{
    			if(s=='O')
    			{
    				cin>>a;
    				work[a]=true;
    				for(i=1;i<=n;++i)
    				{
    					if(i!=a&&work[i]&&dis[i][a])
    						merge(i,a);
    				}
    			}
    			else if(s=='S')
    			{
    				cin>>a>>b;
    				if(find_root(a)==find_root(b))
    					cout<<"SUCCESS"<<endl;
    				else
    					cout<<"FAIL"<<endl;
    			}
    		}
    	}
    	return 0;
    }
    */
    
    //代码二:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<algorithm>
    using namespace std;
    #define N 1110
    int d;
    bool use[N];
    
    struct node
    {
    	int pre;
    	int x, y;
    }p[N];
    
    int find(int x)
    {
    	return x == p[x].pre ? x : find(p[x].pre);
    }
    
    void join(const node p1, const node p2)
    {
    	int root1, root2;
    	root1 = find(p1.pre);
    	root2 = find(p2.pre);
    	if(root1 != root2)
    		if((p1.x - p2.x) * (p1.x - p2.x) + (p1.y - p2.y) * (p1.y - p2.y) <= d * d)
    			p[root2].pre = root1;
    }
    
    int main()
    {
    	//freopen("Input.txt", "r", stdin);
    	int num;
    	char ope;
    	int ok;
    	int from, to;
    	scanf("%d%d", &num, &d);
    	for(int i = 1; i <= num; ++i)
    		p[i].pre = i;
    	memset(use, false, sizeof(use));
    	for(int i = 1; i <= num; ++i)
    		scanf("%d%d", &p[i].x, &p[i].y);
    	while(scanf("\n%c", &ope) != EOF)
    	{
    		if(ope == 'O')
    		{
    			scanf("%d", &ok);
    			use[ok] = true;
    			for(int i = 1; i <= num; ++i)
    				if(use[i] && i != ok)
    					join(p[i], p[ok]);
    		}
    		else
    		{
    			scanf("%d%d", &from, &to);
    			if(find(from) == find(to))
    				printf("SUCCESS\n");
    			else
    				printf("FAIL\n");
    		}
    	}
    	return 0;
    }
    
    功不成,身已退
  • 相关阅读:
    MySQL数据库to_char() to_date()
    爬虫的基本要求和考核标准
    打印MySQL操作错误
    暖通施工时遇到大梁不需要打洞,开小孔的三通时无需放样
    CAD 图纸上的实体的扩展数据不能记数据库中的ID 因为数据库数据删除时,ID也被删除,这样就找不到该实体的信息了
    关于定时关机的命令 shutdown s t 30 at 12:00 shutdown s
    下次坐飞机时,我要揣个弹弓进去, 因为我要去完成我小时候想完成而没能完成的梦想
    CAD 块与块相交,交点在块的边界上,不在块内的某实体上
    豆奶粉干吃好吃
    CAD 我们用弧度时 不要去定义Pi是多少,用Math.Pi
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2602065.html
Copyright © 2011-2022 走看看