zoukankan      html  css  js  c++  java
  • BZOJ3887 [Usaco2015 Jan] Grass Cownoisseur 【tarjan】【DP】*

    BZOJ3887 [Usaco2015 Jan] Grass Cownoisseur


    Description

    In an effort to better manage the grazing patterns of his cows, Farmer John has installed one-way cow paths all over his farm. The farm consists of N fields, conveniently numbered 1..N, with each one-way cow path connecting a pair of fields. For example, if a path connects from field X to field Y, then cows are allowed to travel from X to Y but not from Y to X. Bessie the cow, as we all know, enjoys eating grass from as many fields as possible. She always starts in field 1 at the beginning of the day and visits a sequence of fields, returning to field 1 at the end of the day. She tries to maximize the number of distinct fields along her route, since she gets to eat the grass in each one (if she visits a field multiple times, she only eats the grass there once). As one might imagine, Bessie is not particularly happy about the one-way restriction on FJ’s paths, since this will likely reduce the number of distinct fields she can possibly visit along her daily route. She wonders how much grass she will be able to eat if she breaks the rules and follows up to one path in the wrong direction. Please compute the maximum number of distinct fields she can visit along a route starting and ending at field 1, where she can follow up to one path along the route in the wrong direction. Bessie can only travel backwards at most once in her journey. In particular, she cannot even take the same path backwards twice.
    给一个有向图,然后选一条路径起点终点都为1的路径出来,有一次机会可以沿某条边逆方向走,问最多有多少个点可以被经过?(一个点在路径中无论出现多少正整数次对答案的贡献均为1)

    Input

    The first line of input contains N and M, giving the number of fields and the number of one-way paths (1 <= N, M <= 100,000). The following M lines each describe a one-way cow path. Each line contains two distinct field numbers X and Y, corresponding to a cow path from X to Y. The same cow path will never appear more than once.

    Output

    A single line indicating the maximum number of distinct fields Bessie
    can visit along a route starting and ending at field 1, given that she can
    follow at most one path along this route in the wrong direction.

    Sample Input

    7 10
    1 2
    3 1
    2 5
    2 4
    3 7
    3 5
    3 6
    6 5
    7 2
    4 7

    Sample Output

    6


    给你一张有向图图,有一次走反向边的机会
    然后问你从1出发回到1最多经过多少个点


    首先想到的是tarjan缩点,一个强连通分量的大小显然只要进入了就可以全部吃下来

    然后我们得到了一个DAG
    考虑在这上面走一圈,有一条边可以反向做多能经过多少边

    首先我们显然不能枚举那一个边是反向的,但是我们可以排除这个边随便考虑一下
    我们正反建图,然后发现对于一条边(u>v),把这条边反向的贡献就是d[1>v]+d[u>1],然后我们就分别在正反的图上进行DP,也可以说是跑最长路

    然后最后统计贡献就好了


    tips:一定在DP的时候吧初值设为-INF,否则累计的时候会出事情,要考虑无法到达的情况


    #include<bits/stdc++.h>
    using namespace std;
    #define N 100010
    #define pi pair<int,int>
    #define INF 0x3f3f3f3f
    int cnt_scc,tot=0,n,m;
    int dfn[N],low[N],vis[N]={0};
    int siz[N]={0},head[N]={0};
    int bel[N];
    struct Edge{int u,v,next;}E[N<<1];
    stack<int> s;
    void add(int u,int v){
        E[++tot]=(Edge){u,v,head[u]};
        head[u]=tot;
    }
    int tip=0;
    void tarjan(int u){
        dfn[u]=low[u]=++tip;
        vis[u]=1;
        s.push(u);
        for(int i=head[u];i;i=E[i].next){
            int v=E[i].v;
            if(!dfn[v])tarjan(v),low[u]=min(low[u],low[v]);
            else if(vis[v])low[u]=min(low[u],dfn[v]);
        }
        if(dfn[u]==low[u]){
            cnt_scc++;
            while(s.top()!=u){
                bel[s.top()]=cnt_scc;
                vis[s.top()]=0;
                s.pop();
            }
            vis[s.top()]=0;
            bel[s.top()]=cnt_scc;
            s.pop();
        }
    }
    map<pi,int> mp;
    struct DAG{
        Edge E[N<<1];
        bool inq[N];
        int head[N],tot;
        int dp[N],ru[N];
        DAG(){
            memset(head,0,sizeof(head));
            for(int i=0;i<N;i++)dp[i]=-INF;
            tot=0;
        }
        void add(int u,int v){
            E[++tot]=(Edge){u,v,head[u]};
            head[u]=tot;
        }
        void solve(){
            queue<int> q;
            q.push(bel[1]);
            dp[bel[1]]=0;
            while(!q.empty()){
                int u=q.front();q.pop();
                inq[u]=0;
                for(int i=head[u];i;i=E[i].next){
                    int v=E[i].v;
                    if(dp[v]<dp[u]+siz[v]){
                        dp[v]=dp[u]+siz[v];
                        if(!inq[v])q.push(v),inq[v]=1;
                    }
                }
            }
        }
    }g1,g2;
    int main(){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++){
            int u,v;scanf("%d%d",&u,&v);
            add(u,v);
        }
        for(int i=1;i<=n;i++)if(!dfn[i])tarjan(i);
        for(int i=1;i<=n;i++)siz[bel[i]]++;
        for(int i=1;i<=tot;i++){
            int u=bel[E[i].u],v=bel[E[i].v];
            if(u==v)continue;
            if(mp[(pi){u,v}]||mp[(pi){v,u}])continue;
            g1.add(u,v);
            g2.add(v,u);
            mp[(pi){u,v}]=mp[(pi){v,u}]=1;
        }
        g1.solve();
        g2.solve();
        int ans=0;
        for(int i=1;i<=tot;i++){
            int u=bel[E[i].u],v=bel[E[i].v];
            ans=max(ans,g1.dp[v]+g2.dp[u]);
        }
        ans+=siz[bel[1]];
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    团队第二次作业
    重载和多态
    团队第一次作业
    结对编程
    java处理数字字符串每5个数字为一组进行拆分,保留逗号。不足5个的也存为一组。
    POI & easyExcel快速使用
    Access denied for user 'root'@'localhost' (using password: YES) 解决方法
    快速理解 并发,并行,同步,异步
    Spring Tools Suite 安装于基本使用
    Mysql 数据备份与恢复
  • 原文地址:https://www.cnblogs.com/dream-maker-yk/p/9676284.html
Copyright © 2011-2022 走看看