zoukankan      html  css  js  c++  java
  • 1006 Sign In and Sign Out (25分)

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
     

    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
     

    Sample Output:

    SC3021234 CS301133


    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    #include<string.h>
    #include<cstdlib>
    using namespace std;
    #define mm 1e-8
    const int maxn=1010;
    typedef struct person{
        string name;
        string in;
        string out;
    }per;
    int com(string a,string b){
        int lena=a.length();
        int lenb=b.length();
        int i=0,j=0;
        while(i<lena&&j<lenb){
            if(a[i]>b[j]){
                return 1;
            }else if(a[i]<b[j]){
                return -1;
            }else{
                i++;
                j++;
            }    
        }
    }
    
    int main(){
        per p[maxn];
        int n;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>p[i].name;
            cin>>p[i].in;
            cin>>p[i].out;
        }
        string min=p[0].in;
        string max=p[0].out;
        string minname=p[0].name;
        string maxname=p[0].name;
        for(int i=1;i<n;i++){
            if(com(p[i].in,min)<0){
                min=p[i].in;
                minname=p[i].name;
            }
            if(com(p[i].out,max)>0){
                max=p[i].out;
                maxname=p[i].name;
            }
        }
        cout<<minname<<" "<<maxname<<endl;
        
        return 0;
    } 
  • 相关阅读:
    英语cabardine麝香cabardine单词
    英语dialogite红纹石dialogite菱锰矿
    英语chiltonite葡萄石chiltonite单词
    英语chrysopal金绿宝石chrysopal单词
    Android系统默认对话框添加图片
    入门rocketmq从浅到深
    通用mapper认识和用法
    java开发注解大全
    solr的认识、linux下安装、java下使用(含下载资源)
    RSA签名和验签Util
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14274811.html
Copyright © 2011-2022 走看看