zoukankan      html  css  js  c++  java
  • 1042 Shuffling Machine (20 分)

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, 
    H1, H2, ..., H13, 
    C1, C2, ..., C13, 
    D1, D2, ..., D13, 
    J1, J2
     

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (≤) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
     

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
    题解:定义一个字符串二维数组做中介,用来存放每次变换后的字符,再赋值给原字符数组
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=55;
    string num[55]={"0","S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
                  "H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
                  "C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
                  "D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
                  "J1","J2"};
    string num2[55];//注意,r中的数有的时55,此处定义为54会越界
    int main(){
        int n;
        int r[55];
        r[0]=0;
        scanf("%d",&n);
        for(int i=1;i<=54;i++){
            scanf("%d",&r[i]);
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<55;j++){
                num2[r[j]]=num[j];
            }
            for(int j=1;j<55;j++){
                num[j]=num2[j];
            }
        }
        for(int i=1;i<55;i++){
            if(i<54){
                cout<<num[i]<<" ";
            }
            else{
                cout<<num[i]<<endl;
            }
            
        }
        return 0;
    }
  • 相关阅读:
    STL 全排列
    Happy Programming Contest
    输入外挂
    Crazy Professor
    订票助手 12306
    我的e证空间 出入境证照可在家自拍啦!
    雨生红球藻 虾青素 寻找正规产品!
    CAR 汽车团购网站—广州
    3G路由器、无线接入点(无线AP)、无线路由器!
    微软 Lightswitch 发布 V2 Beta,引入新的逻辑层基础技术!
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14390821.html
Copyright © 2011-2022 走看看