zoukankan      html  css  js  c++  java
  • 1101 Quick Sort (25 分)

    There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

    For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

    • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
    • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
    • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
    • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then the next line contains N distinct positive integers no larger than 1. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:

    5
    1 3 2 4 5
     

    Sample Output:

    3
    1 4 5

    问题代码:
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10000010;
    int m[maxn];
    int mm[maxn];
    int main(){
        int n;
        cin>>n;
        set<int> s;
        for(int i=0;i<n;i++){
            cin>>m[i];
            mm[i]=m[i];
        }
        sort(m,m+n);
        for(int i=0;i<n;i++){
            if(mm[i]==m[i]){
                s.insert(mm[i]);
            }
        }
        cout<<s.size()<<endl;
        set<int>::iterator it;
        it=s.begin();
        cout<<*it;
        it++;
        for(;it!=s.end();it++){
            cout<<" "<<*it;
        }
        return 0;
    
    }

    后续再改进。。。

  • 相关阅读:
    Sencha touch 初体验
    Android开发——NDK开发入门
    Android开发——Activity(活动)的生命周期(上)
    Android开发——构建自定义组件【转】
    Android开发——使用Gallery实现“多级联动”
    Android开发——Android搜索框架(一)
    LINQ之路 6:延迟执行(Deferred Execution)
    .Net小笔记之.NET Framework的内容
    c#高级编程学习笔记之创建一个简化的链表类
    C#高级编程读书笔记之泛型的优点
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14414248.html
Copyright © 2011-2022 走看看