zoukankan      html  css  js  c++  java
  • 1130 Infix Expression (25 分) 树,dfs

    Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

    data left_child right_child
     

    where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

    infix1.JPGinfix2.JPG
    Figure 1 Figure 2

    Output Specification:

    For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

    Sample Input 1:

    8
    * 8 7
    a -1 -1
    * 4 1
    + 2 5
    b -1 -1
    d -1 -1
    - -1 6
    c -1 -1
     

    Sample Output 1:

    (a+b)*(c*(-d))
     

    Sample Input 2:

    8
    2.35 -1 -1
    * 6 1
    - -1 4
    % 7 8
    + 2 3
    a -1 -1
    str -1 -1
    871 -1 -1
     

    Sample Output 2:

    (a*2.35)+(-(str%871))

    dfs


    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    #define  inf  0x3fffffff
    struct node{
        string data;
        int lchild;
        int rchild;
    };
    vector<node> v;
    vector<bool> vis;
    int root;
    string dfs(int index){
        if(index==-1){
            return "";
        }
        if(v[index].rchild!=-1){//若为-1,则该结点没有孩子,不用加()
            v[index].data=dfs(v[index].lchild)+v[index].data+dfs(v[index].rchild);
            if(index!=root){
                v[index].data='('+v[index].data+')';
            }
        }
        return v[index].data;
    }
    int main(){
        int n;
        cin>>n;
        v.resize(n+1);
        vis.resize(n+1);
        for(int i=1;i<=n;i++){
            cin>>v[i].data>>v[i].lchild>>v[i].rchild;
            if(v[i].lchild!=-1){
                vis[v[i].lchild]=true;
            }
            if(v[i].rchild!=-1){
                vis[v[i].rchild]=true;
            }
        }
    
        for(int i=1;i<=n;i++){
            if(vis[i]==false){
                root=i;
                break;
            }
        }
        cout<<dfs(root)<<endl;
        return 0;
    }


  • 相关阅读:
    dubbo学习(一)认识
    MySQL学习(九)小结
    MySQL学习(八)删除表数据
    MySQL学习(六)change-buffer
    RPC 学习(一)认识
    MySQL学习(五)事务隔离
    MySQL学习(四)死锁及死锁检测
    计算机操作系统 --- 进程和进程的上下文切换
    MySQL 学习(三)事务学习
    消息队列(七)--- RocketMQ延时发送和消息重试(半原创)
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14443966.html
Copyright © 2011-2022 走看看