zoukankan      html  css  js  c++  java
  • 1071 Speech Patterns (25 分)

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
     

    Sample Output:

    can 5

    #include<bits/stdc++.h>
    using namespace std;
    map<string,int> mp;
    bool check(char c){
        if(c>='a'&&c<='z'){
            return true;
        }
        if(c>='A'&&c<='Z'){
            return true;
        }
        if(c>='0'&&c<='9'){
            return true;
        }
        return false;
    }
    int main(){
        string s;
        getline(cin,s);
        int len=s.length();
        int i=0;
        for(int i=0;i<len;i++){
            if(s[i]>='A'&&s[i]<='Z'){
                s[i]+=32;
            }
            if(!check(s[i])){
                s[i]=' ';
            }
        }
        while(i<len){
            string st;
            while(i<len&&s[i]!=' '){
                st+=s[i];
                i++;
            }
            if(st!=""){
                if(mp.find(st)==mp.end()){
                    mp[st]=1;
                }
                else{
                    mp[st]++;
                }
            }
            while(i<len&&s[i]==' '){
                i++;
            }
        }
        string ans;
        int maxC=-1;
        for(map<string,int>::iterator it=mp.begin();it!=mp.end();it++){
            if(it->second>maxC){
                maxC=it->second;
                ans=it->first;
            }
        }
        cout<<ans<<" "<<maxC<<endl;
        return 0;
    }
  • 相关阅读:
    强化学习
    训练深度神经网络失败的罪魁祸首是退化
    wod2vec&fasttext&doc2vec#ida2vec
    leetcode动态规划之最长回文子串
    数据增强
    【认证与授权】Spring Security自定义页面
    【认证与授权】Spring Security的授权流程
    【认证与授权】Spring Security系列之认证流程解析
    【认证与授权】Spring Security系列之初体验
    【认证与授权】2、基于session的认证方式
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14454129.html
Copyright © 2011-2022 走看看