zoukankan      html  css  js  c++  java
  • 1117 Eddington Number (25 分)

    British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

    Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤).

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

    Output Specification:

    For each case, print in a line the Eddington number for these N days.

    Sample Input:

    10
    6 7 6 9 3 10 8 2 7 8
     

    Sample Output:

    6
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    bool cmp(int a,int b){
        return a>b;
    }
    int main(){
        vector<int> v;
        int n;
        cin>>n;
        v.resize(n);
        for(int i=0;i<n;i++){
            cin>>v[i];
        }
        sort(v.begin(),v.end(),cmp);
        int E=0;
        while(E<n&&v[E]>E+1){
            E++;
        }
        cout<<E<<endl;
        return 0;
    }
     
  • 相关阅读:
    转DataBinder.Eval总结
    ASP.NET环境下XML导出导入数据方法
    iOS开发中GCD在多线程方面的理解
    hdu 1678 优先队列
    hdu 1565 状态压缩DP
    hdu 1175 连连看
    hdu 1078 记忆化搜索
    hdu 1506
    hdu 1521 记忆化搜索
    三大博弈[转]
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14460776.html
Copyright © 2011-2022 走看看