zoukankan      html  css  js  c++  java
  • 1077 Kuchiguse (20 分)

    The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

    • Itai nyan~ (It hurts, nyan~)

    • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

    Sample Input 1:

    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
     

    Sample Output 1:

    nyan~
     

    Sample Input 2:

    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
     

    Sample Output 2:

    nai

    注意getline对回车键的读入

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100010;
    int main(){
        int n;
        scanf("%d
    ",&n);//注意:一定要加
      ;  如果发现输出少了,一定要检查是否读入空格
        string str,ans;
        for(int i=0;i<n;i++){
            getline(cin,str);
            int lens=str.length();
            reverse(str.begin(),str.end());
            if(i==0){
                ans=str;
            }
            else{
                int lena=ans.length();
                if(lens<lena){
                    swap(str,ans);
                }
                int len=min(lena,lens);
                for(int j=0;j<len;j++){
                    if(str[j]!=ans[j]){
                        ans=ans.substr(0,j);//左闭右开
                        break;
                    }
                }
            }
        }
        reverse(ans.begin(),ans.end());
        if(ans.length()>0){
                cout<<ans<<endl;
            }
            else{
                cout<<"nai"<<endl;
            }
        
        return 0;
    }
  • 相关阅读:
    用代理IP进行简单的爬虫——爬高匿代理网站
    python利用django实现简单的登录和注册,并利用session实现了链接数据库
    python基础知识——基于python3.6
    笔记2_列表、元组、字典
    wpf Command
    可枚举对象操作
    2019寒假训练营寒假作业(二) 程序题部分
    2019-01-23 寒假作业(一)
    2019寒假训练营第二次作业
    网络空间安全概论 学习笔记(二)
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14466013.html
Copyright © 2011-2022 走看看