zoukankan      html  css  js  c++  java
  • 1082 Read Number in Chinese (25 分)

    Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

    Input Specification:

    Each input file contains one test case, which gives an integer with no more than 9 digits.

    Output Specification:

    For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

    Sample Input 1:

    -123456789
     

    Sample Output 1:

    Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
     

    Sample Input 2:

    100800
     

    Sample Output 2:

    yi Shi Wan ling ba Bai
     
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100010;
    char num[10][5]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
    char wei[5][5]={"Shi","Bai","Qian","Wan","Yi"};
    int main(){
        string st;
        cin>>st;
        int len=st.length();
        int left=0,right=len-1;
        if(st[0]=='-'){
            printf("Fu");
            left++;
        }
        while(left+4<=right){
            right-=4;
        }
        while(left<len){
            bool flag=false;
            bool isprint=false;
            while(left<=right){
                if(left>0&&st[left]=='0'){
                    flag=true;
                }
                else{
                    if(flag==true){
                        printf(" ling");
                        flag=false;
                    }
                    if(left>0){
                    printf(" ");
                    }
                    printf("%s",num[st[left]-'0']);
                    isprint=true;
                    if(left!=right){
                        printf(" %s",wei[right-left-1]);
                    }
                }
                left++;
            }
            if(isprint==true&&right!=len-1){
                printf(" %s",wei[(len-1-right)/4+2]);
            }
            right+=4;
        }
        
        return 0;
    }
  • 相关阅读:
    https-->http and http-->https bitransfer
    socat
    docker daemon configuration
    centos 7 update to python V3.43 to assure git clone as usual
    df and du
    SS iproute2,nslookup,dig
    jmxtrans
    web.xml之env-entry
    Java发送Http请求
    elasticsearch在CentOS环境下开机启动
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14470024.html
Copyright © 2011-2022 走看看