zoukankan      html  css  js  c++  java
  • 1124 Raffle for Weibo Followers (20 分)

    John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

    Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

    Output Specification:

    For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

    Sample Input 1:

    9 3 2
    Imgonnawin!
    PickMe
    PickMeMeMeee
    LookHere
    Imgonnawin!
    TryAgainAgain
    TryAgainAgain
    Imgonnawin!
    TryAgainAgain
     

    Sample Output 1:

    PickMe
    Imgonnawin!
    TryAgainAgain
     

    Sample Input 2:

    2 3 5
    Imgonnawin!
    PickMe
     

    Sample Output 2:

    Keep going...
     思路:i从第一个下标开始遍历,如果其对应的选手没有获胜,就间隔n继续遍历,如果获胜,就+1继续遍历,用map存储是否获胜
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10010;
    string s[maxn];
    map<string,bool> mp;
    
    int main(){
        int m,n,t;
        cin>>m>>n>>t;
        for(int i=0;i<m;i++){
            cin>>s[i];
            mp[s[i]]=false;
        }
        if(m<t){
            cout<<"Keep going..."<<endl;
            return 0;
        }
        int k=0;
        for(int i=t-1;i<m; ){
            if(mp[s[i]]==false){
                cout<<s[i]<<endl;
                mp[s[i]]=true;
                i+=n;
            }
            else{
                i++;
            }
        }
        return 0;
    }

  • 相关阅读:
    6次作业
    5次作业
    4次作业
    3次作业
    first 作业
    pycharm快捷键
    python基础知识记录
    Jenkins+sonar+tomcat+SVN集成搭建
    成为1个技术大牛的入门到进阶之路(学习路线图)
    记一次收到QQ邮箱钓鱼邮件经历
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14924832.html
Copyright © 2011-2022 走看看