zoukankan      html  css  js  c++  java
  • 1071 Speech Patterns (25 分)

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
     

    Sample Output:

    can 5
     
     思路:将字符转换为合法字符,不合法的用#代替,再将大写转化为小写,利用#剪切字符串并建立map映射
     
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    map<string,int> mp;
    bool judge(char a){
        if(a>='A'&&a<='Z'){
            return true;
        }
        else if(a>='a'&&a<='z'){
            return true;
        }
        else if(a>='0'&&a<='9'){
            return true;
        }
        else {
            return false;
        }
    }
    int main(){
        string st;
        getline(cin,st);
        for(int i=0;i<st.size();i++){
            if(st[i]>='A'&&st[i]<='Z'){
                st[i]=st[i]+32;
            }
            if(!judge(st[i])){
                st[i]='#';
            }
        }
        for(int i=0;i<st.size();i++){
            string s="";
            while(st[i]!='#'){
                s+=st[i];
                i++;
            }
            if(s!=""){
                mp[s]++;
            }
            
        }
        int maxv=-1;
        string temp;
        for(map<string,int>::iterator it=mp.begin();it!=mp.end();it++){
            if(it->second>maxv){
                maxv=it->second;
                temp=it->first;
            }
        }
        cout<<temp<<" "<<maxv<<endl;
        return 0;
    }
  • 相关阅读:
    小程序那些坑
    2018-5-31 项目总结
    Android AndroidManifest学习笔记
    android 快捷键
    android的liveview装载数据
    android xml产生和解析
    SerializableMaplist传递数据
    android hander 线程用法
    DataGridView实现分页
    DataGridView添加另外一个控件。
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14965271.html
Copyright © 2011-2022 走看看