zoukankan      html  css  js  c++  java
  • 1022 Digital Library (30 分)

    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    • Line #1: the 7-digit ID number;
    • Line #2: the book title -- a string of no more than 80 characters;
    • Line #3: the author -- a string of no more than 80 characters;
    • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    • Line #5: the publisher -- a string of no more than 80 characters;
    • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (≤) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    • 1: a book title
    • 2: name of an author
    • 3: a key word
    • 4: name of a publisher
    • 5: a 4-digit number representing the year

    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
     

    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found
    写代码20分钟,找bug一晚上系列
    这代码充满太多灵异
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=110;
    typedef struct Libray{
        int ID;
        string name;
        string aut;
        set<string> keyw;
        string pub;
        string year;
    }Lib;
    int n;
    Lib lib[maxn];
    void judge(string s){
        bool flag;
        int len=s.size();
        string st=s.substr(0,len-3);
        cout<<st<<"ok?"<<endl;
        if(s[0]=='1'){
            for(int i=0;i<n;i++){
                if(lib[i].name==st){
                    cout<<lib[i].ID<<endl;
                    flag=true;
                }
            }
        }
        if(s[0]=='2'){
            for(int i=0;i<n;i++){
                if(lib[i].aut==st){
                    cout<<lib[i].ID<<endl;
                    flag=true;
                }
            }
        }
        if(s[0]=='3'){
            for(int i=0;i<n;i++){
                if(lib[i].keyw.find(st)!=lib[i].keyw.end()){
                    cout<<lib[i].ID<<endl;
                    flag=true;
                }
            }
        }
        if(s[0]=='4'){
            for(int i=0;i<n;i++){
                if(lib[i].pub==st){
                    cout<<lib[i].ID<<endl;
                    flag=true;
                }
            }
        }
        if(s[0]=='5'){
            for(int i=0;i<n;i++){
                if(lib[i].year==st){
                    cout<<lib[i].ID<<endl;
                    flag=true;
                }
            }
        }
        if(flag==false){
            cout<<"Not Found"<<endl;
        }
    }
    int main(){
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>lib[i].ID;
            getline(cin,lib[i].name);
            getline(cin,lib[i].aut);
            string st,stt="";
            getline(cin,st);
            for(int j=0;j<st.size();j++){
                if(st[j]!=' '){
                    stt+=st[j];
                }
                else if(st[j]==' '&&stt!=""){
                    lib[i].keyw.insert(stt);
                    stt="";
                }
            }
            getline(cin,lib[i].pub);
            getline(cin,lib[i].year);
            cout<<"oo"<<endl;
        }
        int m;
        cin>>m;
        for(int i=0;i<m;i++){
            string s;
            getline(cin,s);
            judge(s);
        }
        return 0;
    }
  • 相关阅读:
    bzoj3033: 太鼓达人
    CH Round #24
    王志明:编辑部不送审,把你的投稿直接拒掉了,怎么办?
    用TinyXml做XML解析示例 TinyXml查找唯一节点及修改节点操作
    QT XML文档的解析 QXmlStreamReader, DOM,SAX 三种解析方法 简单示例
    QT 使用QUdpSocket QUdpServer UDP 建立客户端与服务器端
    QT 使用QTcpServer QTcpSocket 建立TCP服务器端 和 客户端
    Qt QThread 线程创建,线程同步,线程通信 实例
    Qt QT的IO流 QT输入输出
    Qt QSortFilterProxyModel示例代码, 使用方法
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14970297.html
Copyright © 2011-2022 走看看