zoukankan      html  css  js  c++  java
  • HDU 1159 Common Subsequence (动态规划、最长公共子序列)

    Common Subsequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 55301    Accepted Submission(s): 25537

     

    Problem Description

     

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

    Sample Input

    abcfbc abfcab
    programming contest 
    abcd mnp

    Sample Output

    4
    2
    0

    题目大意与分析

    就是求最长公共子序列,动态规划即可。

    dp[i][j]代表A序列前i-1个元素与B序列前j-1个元素的最长公共子序列的个数,两层循环,相等就++,否则取当前最大的

    代码

    #include<bits/stdc++.h>
    
    using namespace std;
    
    string x,y;
    int i,j,dp[1005][1005];
    
    int main()
    {
        while(cin>>x>>y)
        {
            memset(dp,0,sizeof(dp));
            for(i=0;i<x.size();i++)
            {
                for(j=0;j<y.size();j++)
                {
                    if(x[i]==y[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                    else
                    dp[i+1][j+1]=max(dp[i+1][j],dp[i][j+1]);
                }
            }
            cout<<dp[x.size()][y.size()]<<endl;
        }
    }

     

  • 相关阅读:
    php测试数据库
    mysql查
    mysql增删改
    mysql数据类型
    Docker 探索安装WordPress+Mysql8.0
    Docker For MYSQL 8.0 特别注意修复数据库新的验证方式
    Docker EE/Docker CE简介与版本规划
    Hyper和Vmware冲突,Device/Credential Guard 不兼容
    利用阿里云加速Docker For Windows
    使用Aliyun Docker 容器镜像/注册表服务
  • 原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/11392138.html
Copyright © 2011-2022 走看看