zoukankan      html  css  js  c++  java
  • POJ 2492 A Bug's Life (种类并查集)

    A Bug's Life

    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 52818   Accepted: 16983

    Description

    Background
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
    Problem
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

    Input

    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

    Output

    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

    Sample Input

    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4

    Sample Output

    Scenario #1:
    Suspicious bugs found!
    
    Scenario #2:
    No suspicious bugs found!

    题目大意与分析

    n个虫子,m个关系,每个关系代表a和b能交配,要求找出有没有同性恋虫子

    这个题和POJ1703类似,也是用种类并查集做,对于输入的ab,查询是否属于同一个祖先即可

    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    #include <vector>
    #include <stack>
    #include <queue>
    #include <algorithm>
    #include <math.h>
    #include <cstdio>
    using namespace std;
    
    int s[4005],t,n,m,k=0,flag;
    
    int findf(int x)
    {
        return x==s[x]?x:s[x]=findf(s[x]);
    }
    
    void hebing(int x,int y)
    {
        int fx=findf(x);
        int fy=findf(y);
        if(fx!=fy)
        {
            s[fx]=fy;
        }
    }
    
    int main()
    {
        cin>>t;
        while(t--)
        {
            k++;
            flag=0;
            cin>>n>>m;
            for(int i=1;i<=2*n;i++)
            {
                s[i]=i;
            }
            while(m--)
            {
                int a,b;
                cin>>a>>b;
                if(findf(a)==findf(b))
                {
                    flag=1;
                }
                else
                {
                    hebing(a,b+n);
                    hebing(a+n,b);
                }
            }
            cout<<"Scenario #"<<k<<":"<<endl;
            if(flag==1)
            {
                cout<<"Suspicious bugs found!"<<endl;
            }
            else
            {
                cout<<"No suspicious bugs found!"<<endl;
            }
            cout<<endl;
        }
    }
  • 相关阅读:
    最常用的vim操作指令练习记录
    数据库中间件——Mycat配置
    分布式事务解决方案seata之AT模式原理剖析
    分布式服务限流降级熔断解决方案Nacos之Dashboard界面配置含义记录
    本地Centos7虚拟机安装rabbitmq,主宿机无法访问监控界面解决
    dubbo学习笔记
    SpringBoot整合mybatis-plus代码生成器(备用)
    Zookeeper大概配置及与java集成使用
    Adb免root卸载Android预装应用
    腾讯X5内核调试(安卓)
  • 原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/12550777.html
Copyright © 2011-2022 走看看