zoukankan      html  css  js  c++  java
  • HDU 1240 Asteroids! (三维bfs)

    Asteroids!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7089    Accepted Submission(s): 4386


    Problem Description
    You're in space.
    You want to get home.
    There are asteroids.
    You don't want to hit them.
     
    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

    A single data set has 5 components:

    Start line - A single line, "START N", where 1 <= N <= 10.

    Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

    'O' - (the letter "oh") Empty space

    'X' - (upper-case) Asteroid present

    Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

    Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

    End line - A single line, "END"

    The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

    The first coordinate in a set indicates the column. Left column = 0.

    The second coordinate in a set indicates the row. Top row = 0.

    The third coordinate in a set indicates the slice. First slice = 0.

    Both the Starting Position and the Target Position will be in empty space.

     
    Output
    For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

    A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

    A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

     
    Sample Input
    START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END
     
    Sample Output
    1 0 3 4 NO ROUTE
     

    题目大意与分析

    给出三维的地图,x不能走,o可以走,bfs做即可,需要注意的是,地图是按照切面给的,所以在读地图的时候,首先遍历的应该是z轴

    #include<bits/stdc++.h>
    using namespace std;
    
    int f[3][6]={1,-1,0,0,0,0,0,0,1,-1,0,0,0,0,0,0,1,-1},vis[20][20][20],mp[20][20][20],n,i,j,k,sx,sy,sz,px,py,pz,anss;
    char x;
    string s;
    
    int main()
    {
        while(cin>>s>>n)
        {
            anss=-1;
            memset(vis,0,sizeof(vis));
            queue<int>q; 
            for(i=0;i<n;i++)
            {
                for(j=0;j<n;j++)
                {
                    for(k=0;k<n;k++)
                    {
                        cin>>x;
                        if(x=='O')
                        mp[j][k][i]=1;
                        else
                        mp[j][k][i]=0;
                    }
                }
            }
            cin>>sx>>sy>>sz;
            cin>>px>>py>>pz;
            q.push(sx);
            q.push(sy);
            q.push(sz);
            q.push(0);
            vis[sx][sy][sz]=1;
            while(!q.empty())
            {
                int x=q.front();
                q.pop();
                int y=q.front();
                q.pop();
                int z=q.front();
                q.pop();
                int step=q.front();
                q.pop();
                if(x==px&&y==py&&z==pz)
                {
                    anss=step;
                    break;
                }
                for(i=0;i<6;i++)
                {
                    int xx=x+f[0][i];
                    int yy=y+f[1][i];
                    int zz=z+f[2][i];
                    if(xx>=0&&xx<n&&yy>=0&&yy<n&&zz>=0&&zz<n&&mp[xx][yy][zz]==1&&vis[xx][yy][zz]==0)
                    {
                        q.push(xx);
                        q.push(yy);
                        q.push(zz);
                        q.push(step+1);
                        vis[xx][yy][zz]=1;
                    }
                }
            }
            cin>>s;
            if(anss!=-1)
            {
                cout<<n<<' '<<anss<<endl;
            }
            else
            {
                cout<<"NO ROUTE"<<endl;
            }
        }
    }
  • 相关阅读:
    奇怪的肚疼
    惊喜:vs2005 和 msdn 中文版 已经提供Subscriber 下载,MSDN全球订户可以下中文版爽了
    英语构语法(前、后缀部分)
    TSQL中的递归 作者:Alexander Kozak
    筹划向 Visual Studio 2005 导航控件的迁移 作者:Dave Donaldson Steven DeWalt
    Atlas客服端文件介绍
    Chinese lunar calendar for www.live.com
    帮助解决网页和JS文件中的中文编码问题的小工具
    ADO.NET 2.0 功能一览 作者:Bob Beauchemin
    Prototype.js 1.4中文使用手册PDF版下载
  • 原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/12627614.html
Copyright © 2011-2022 走看看