zoukankan      html  css  js  c++  java
  • poj 2255 Tree Recovery

    Tree Recovery
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9658   Accepted: 6067

    Description

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
    This is an example of one of her creations: 
                                                   D
    
                                                  / 
    
                                                 /   
    
                                                B     E
    
                                               /      
    
                                              /        
    
                                             A     C     G
    
                                                        /
    
                                                       /
    
                                                      F
    
    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
    However, doing the reconstruction by hand, soon turned out to be tedious. 
    So now she asks you to write a program that does the job for her! 

    Input

    The input will contain one or more test cases. 
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
    Input is terminated by end of file. 

    Output

    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

    Sample Input

    DBACEGF ABCDEFG
    BCAD CBAD
    

    Sample Output

    ACBFGED
    CDAB
    

    Source

    /*
    大概意思:给你二叉树的前序遍历,和中序遍历,求后续遍历,和hdu上的1710差不多
    只是这题是单个字符,可以用字符串直接截取
    */
    import java.util.Scanner;
    public class Main{//AC
    	static String s;
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		while(input.hasNext()){
    			String pre=input.next();
    			String rin=input.next();
    			Node node=BT(pre,rin);//建立根节点
    			PO(node);
    			System.out.println();
    		}
    	}
    	private static void PO(Node node) {//后续遍历
    		if(node!=null){
    			PO(node.lchild);
    			PO(node.rchild);
    			System.out.print(node.data);
    		}
    		
    	}
    	private static Node BT(String pre, String rin) {
    		if(pre.length()<=0)
    			return null;
    			//保存根节点
    		char gen=pre.charAt(0);
    		Node gjd=new Node(gen);
    			//以根节点为边界,把中序序列分成左右两个子树的中序序列
    		int index=rin.indexOf(gen);
    		String lrin=rin.substring(0, index);
    		String rrin=rin.substring(index+1,rin.length());
    			//以中序序列的长度,把除了根节点的前序序列分成左右两个子树的前序序列
    		String lpre=pre.substring(1,lrin.length()+1);
    		String rpre=pre.substring(lrin.length()+1, pre.length());
    			//递归继续分解左右子树
    		gjd.lchild=BT(lpre,lrin);
    		gjd.rchild=BT(rpre,rrin);
    		return gjd;
    	}
    }
    class Node{//声明二叉树
    	char data;
    	Node lchild;
    	Node rchild;
    	Node(char data){
    		this.data=data;
    		this.lchild=null;
    		this.rchild=null;
    	}
    }



  • 相关阅读:
    MySQL —— 程序连接时的驱动名称和URL
    这该称作什么效应?
    Java 基础 面向对象之关键字内部类代码块修饰符
    Java 基础 面向对象之构造方法和关键字
    Java 基础 接口和多态
    Java 基础 面向对象和抽象类
    Java 基础 引用数据类型 ArrayList集合
    Java 基础 方法
    Java 基础 引用数据类型 和 流程控制
    Mongodb 基础 复制集原理和搭建
  • 原文地址:https://www.cnblogs.com/dyllove98/p/3231048.html
Copyright © 2011-2022 走看看