zoukankan      html  css  js  c++  java
  • poj 1611 The Suspects(并查集)

    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 18723   Accepted: 9041

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    Source


    /*
     求所有和0号在一个集合的有多少人
     */
    import java.util.Scanner;
    
    public class Main{//并查集
    	private static int str[];
    	private static int rank[];
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		while(true){
    			int n=input.nextInt();
    			int m=input.nextInt();
    			if(n==0&&m==0)
    				break;
    			str=new int[n+1];
    			rank=new int[n+1];//标记深度
    			for(int i=0;i<n;i++){//初始化
    				str[i]=i;
    				rank[i]=1;
    			}
    			
    			while(m-->0){//合并集合
    				int k=input.nextInt();
    				int a=0,b=0;
    				if(k>=1)
    					a=input.nextInt();
    				for(int i=1;i<k;i++){
    					b=input.nextInt();
    					heBing(a,b);
    				}
    			}
    			int sum=1;
    			for(int i=1;i<n;i++){//查找和0在同一集合的人数个数
    				if(find(0)==find(i))
    					sum++;
    			}
    			System.out.println(sum);
    		}
    	}
    
    	private static void heBing(int a, int b) {
    		int x=find(a);
    		int y=find(b);
    		if(x==y)
    			return;
    		if(rank[x]>rank[y]){//让深度小的合并到深度深的里面
    			str[y]=x;
    		}
    		else{
    			str[x]=y;
    			if(rank[x]==rank[y])//记这每次深度的变化
    				rank[y]++;
    		}
    	}
    
    	private static int find(int a) {//寻找根节点
    		while(a!=str[a])
    			a=str[a];
    		return a;
    	}
    }


  • 相关阅读:
    com.alibaba.fastjson.JSONException: default constructor not found. class ……
    ActiveMQ伪集群部署
    #{}和${}的区别
    微信小程序——报错汇总
    PHP——base64的图片的另类上传方法
    PHP——base64的图片转为文件图片
    veu——引入iconfont图标
    vue——script内容详解
    webpack——阮一峰webpackDemo分析
    webpack——快速入门【一】
  • 原文地址:https://www.cnblogs.com/dyllove98/p/3238913.html
Copyright © 2011-2022 走看看