zoukankan      html  css  js  c++  java
  • [Jobdu] 题目1005:Graduate Admission

    题目描述:

        It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
        Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

        • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
        • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
        • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
        • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

    输入:

        Each input file may contain more than one test case.
        Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
        In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
        Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

    输出:

        For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

    样例输入:
    11 6 3
    2 1 2 2 2 3
    100 100 0 1 2
    60 60 2 3 5
    100 90 0 3 4
    90 100 1 2 0
    90 90 5 1 3
    80 90 1 0 2
    80 80 0 1 2
    80 80 0 1 2
    80 70 1 3 2
    70 80 1 2 3
    100 100 0 2 4
    样例输出:
    0 10
    3
    5 6 7
    2 8
    
    1 4
     
    #include <iostream>
    #include <vector>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    struct student{
        int id;
        int final;
        int GE;
        int GI;
        vector<int> s;
        bool flag;
    };
    
    int N,M,K;
    vector<student> v;
    vector<int> s;
    vector<vector<student> > r;
    student *p;
    
    bool comp(student a,student b){
        if(a.final!=b.final){
            return a.final>b.final;
        }
        else{
            return a.GE>b.GE;
        }
    }
    
    bool comp2(student a,student b){
        return a.id<b.id;
    }
    
    void getRes(){
        sort(v.begin(),v.end(),comp);
        for(int i=0;i<N;i++){
            for(int k=0;k<K;k++){
                //cout<<boolalpha<<v[i].flag<<endl;
                if(!v[i].flag){
                    if(s[v[i].s[k]]>0){
                        s[v[i].s[k]]--;
                        v[i].flag = true;
                        r[v[i].s[k]].push_back(v[i]);
                    }
                    else if(v[i].GE==r[v[i].s[k]].back().GE
                            &&v[i].GI==r[v[i].s[k]].back().GI){
                        v[i].flag = true;
                        r[v[i].s[k]].push_back(v[i]);
                    }
                }
            }
        }
        for(int i=0;i<M;i++){
            sort(r[i].begin(),r[i].end(),comp2);
            if(r[i].size()==0){
                cout<<endl;
            }
            else{
                for(int j=0;j<r[i].size();j++){
                    if(j==r[i].size()-1){
                        cout<<r[i][j].id<<endl;
                        break;
                    }
                    cout<<r[i][j].id<<" ";
                }
            }
        }
    }
    
    int main(int argc,char* argv[]){
        //freopen("input.txt","r",stdin);
        while(cin>>N>>M>>K){
            v.resize(N);
            s.resize(M);
            r.resize(M);
            for(int i=0;i<M;i++){
                r[i].clear();
                cin>>s[i];
            }
            for(int i=0;i<N;i++){
                v[i].id = i;
                v[i].flag = false;
                cin>>v[i].GE>>v[i].GI;
                v[i].final = v[i].GE + v[i].GI;
                v[i].s.resize(K);
                for(int j=0;j<K;j++){
                    cin>>v[i].s[j];
                }
            }
            getRes();
        }
        return 0;
    }
    

      

  • 相关阅读:
    用Sqoop进行Hive和MySQL之间的数据互导
    Spark读HBase写MySQL
    Kafka如何彻底删除topic及数据
    LDAP-HA安装与配置(Keepalived方式实现)
    配置两个Hadoop集群Kerberos认证跨域互信
    MYSQL HA 部署手册
    ELK简单安装测试
    Elasticsearch CURL命令
    大数据常见错误解决方案(转载)
    生成 RSA 公钥和私钥的方法
  • 原文地址:https://www.cnblogs.com/easonliu/p/2617529.html
Copyright © 2011-2022 走看看