zoukankan      html  css  js  c++  java
  • Network Saboteur (DFS暴力枚举)

    A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
    A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
    Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
    The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

    Input

    The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
    Output file must contain a single integer -- the maximum traffic between the subnetworks. 

    Output

    Output must contain a single integer -- the maximum traffic between the subnetworks.

    Sample Input

    3
    0 50 30
    50 0 40
    30 40 0
    

    Sample Output

    90
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<set>
    #include<vector>
    #include<stack>
    #include<queue>
    #include<algorithm>
    #include<cstdio>
    #include<algorithm>
    #include<functional>
    #include<sstream>
    using namespace std;
    const int Max = 21;
    const bool A = true;
    const bool B = false;
    int n, map[Max][Max], ans = 0;
    bool Set[Max];
    void dfs(int dep, int sum)
    {
        if (dep > n) {
            if (sum > ans)
                ans = sum;
            return;
        }
        int m;
        m = 0;
        Set[dep] = A;
        for (int i = 1; i <= dep; i++)
            if (Set[i] == B)
                m += map[i][dep];
        dfs(dep + 1, sum + m);
    
        m = 0;
        Set[dep] = B;
        for (int i = 1; i <= dep; i++)
            if (Set[i] == A)
                m += map[i][dep];
        dfs(dep + 1, sum + m);
    }
    
    int main()
    {
        cin >> n;
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++)
                cin >> map[i][j];
        dfs(1, 0);
        cout << ans << endl;
        return 0;
    }
  • 相关阅读:
    【机器学习】关于判别模型和生成模型
    Delphi新手跟我学写CALL,附完整原程序
    QT事件研究的文章
    杂烩:QWidget、QGraphics、QtQuick
    Golang全接触
    学会使用git
    代码创建 WPF 旋转动画
    值得推荐的C/C++框架和库 very good
    可恶的QT隐式共享
    Notes on OpenSSL and Qt(ssl.pri,qsslocket_openssl_symbols.cpp)
  • 原文地址:https://www.cnblogs.com/edych/p/7243176.html
Copyright © 2011-2022 走看看