zoukankan      html  css  js  c++  java
  • Unique Snowflakes

    Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package. Once the package is full, it is closed and shipped to be sold. The marketing motto for the company is “bags of uniqueness.” To live up to the motto, every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical. Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time, but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed. The package can be completed and sealed before all of the snowflakes have flowed out of the machine.

    Input

    The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine. The following n lines each contain an integer (in the range 0 to 109 , inclusive) uniquely identifying a snowflake. Two snowflakes are identified by the same integer if and only if they are identical. The input will contain no more than one million total snowflakes.

    Output

    For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.

    Sample Input

    1 5 1 2 3 2 1

    Sample Output

    3

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<set>
    #include<vector>
    #include<stack>
    #include<queue>
    #include<algorithm>
    #include<cstdio>
    #include<algorithm>
    #include<functional>
    #include<sstream>
    using namespace std;
    const int maxn = 1000000 + 5;
    int a[maxn];
    
    int main() {
        set<int> s;
        int cases, n;
        cin >> cases;
    
        while (cases--) {
            cin >> n;
            for (int i = 0; i<n; i++) cin >> a[i];
    
            s.clear();
            int left = 0, right = 0, ans = 0;
            while (right < n) {
                while (right < n && !s.count(a[right])) s.insert(a[right++]);
                ans = max(ans, right - left);
                s.erase(a[left++]);
            }
            cout << ans << endl;
        }
        return 0;
    }

    题意:给出 n个数,找到尽量长的一个序列,使得该序列中没有重复的元素

    思路:对于该类段查找问题可以采用经典的滑动窗口方法,即维护一个窗口,窗口的左右边界用两个变量L,R代表,先增加R直到出现重复数字,再增加L,再增加R,直到R达到n

  • 相关阅读:
    mysql,apache,php的关系
    简析 Tomcat 、Nginx 与 Apache 的区别
    Linux中涉及到环境变量的文件
    如何在Linux启动的时候执行一个命令
    sed的额外用法(网摘)
    shell脚本执行方式
    在rhel7上搭建centos7的yum源
    MYSQL三种安装方式--二进制包安装
    ssh连接不上排查方法总结
    MySQL启动很慢的原因
  • 原文地址:https://www.cnblogs.com/edych/p/7281519.html
Copyright © 2011-2022 走看看