读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名
和学号
均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
代码
// b1004-成绩排名.cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//
#include <iostream>
using namespace std;
int main()
{
int n;
cin >> n;
int max = -1;
int min = 101;
string max_name, max_code;
string min_name, min_code;
string this_name, this_code;
int this_grade;
for (int i = 0; i < n; i++) {
cin >> this_name >> this_code >> this_grade;
if (this_grade > max) {
max = this_grade;
max_name = this_name;
max_code = this_code;
}
if (this_grade < min) {
min = this_grade;
min_name = this_name;
min_code = this_code;
}
}
cout << max_name << " " << max_code << endl << min_name << " " << min_code;
return 0;
}