zoukankan      html  css  js  c++  java
  • zoj2972Hurdles of 110m(dp)

    Hurdles of 110m
    Time Limit: 2000 msMemory Limit: 65536 KB

    In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China and Beijing Olympics is to be a festival for people all over the world as well.

    Liu Xiang is one of the famous Olympic athletes in China. In 2002 Liu broke Renaldo Nehemiah's 24-year-old world junior record for the 110m hurdles. At the 2004 Athens Olympics Games, he won the gold medal in the end. Although he was not considered as a favorite for the gold, in the final, Liu's technique was nearly perfect as he barely touched the sixth hurdle and cleared all of the others cleanly. He powered to a victory of almost three meters. In doing so, he tied the 11-year-old world record of 12.91 seconds. Liu was the first Chinese man to win an Olympic gold medal in track and field. Only 21 years old at the time of his victory, Liu vowed to defend his title when the Olympics come to Beijing in 2008.

    In the 110m hurdle competition, the track was divided into N parts by the hurdle. In each part, the player has to run in the same speed; otherwise he may hit the hurdle. In fact, there are 3 modes to choose in each part for an athlete -- Fast Mode, Normal Mode and Slow Mode. Fast Mode costs the player T1 time to pass the part. However, he cannot always use this mode in all parts, because he needs to consume F1 force at the same time. If he doesn't have enough force, he cannot run in the part at the Fast Mode. Normal Mode costs the player T2 time for the part. And at this mode, the player's force will remain unchanged. Slow Mode costs the player T3 time to pass the part. Meanwhile, the player will earn F2 force as compensation. The maximal force of a player is M. If he already has M force, he cannot earn any more force. At the beginning of the competition, the player has the maximal force.

    The input of this problem is detail data for Liu Xiang. Your task is to help him to choose proper mode in each part to finish the competition in the shortest time.

    Input

    Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

    Each test case begins with two positive integers N and M. And following N lines denote the data for the N parts. Each line has five positive integers T1 T2 T3 F1 F2. All the integers in this problem are less than or equal to 110.

    Output

    Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the shortest time that Liu Xiang can finish the competition.

    Sample Input

    2
    1 10
    1 2 3 10 10
    4 10
    1 2 3 10 10
    1 10 10 10 10
    1 1 2 10 10
    1 10 10 10 10
    

    Sample Output

    1
    6
    

    Hint

    For the second sample test case, Liu Xiang should run with the sequence of Normal Mode, Fast Mode, Slow Mode and Fast Mode.

    根据每轮所剩体力值来DP,dp[i][j]数组的值表示第i个栏时,剩j点体力所需的最小时间

    #include<bits/stdc++.h>
    using namespace std;
    int main(){
    unsigned dp[111][111], t,n,m,t1,t2,t3,f1,f2,res,temp,i,j;
    cin>>t;
    while(t--){
    cin>>n>>m;
    memset(dp,-1,sizeof dp);
    memset(dp[0],0,sizeof dp[0]);
    for(i=1;i<=n;i++){
    cin>>t1>>t2>>t3>>f1>>f2;

    for(j=0;j<=m;j++){
    dp[i][j]=min(dp[i-1][j]+t2,dp[i][j]);
    if(j>=f1)
    dp[i][j-f1]=min(dp[i-1][j]+t1,dp[i][j-f1]);
    temp=min(j+f2,m);
    dp[i][temp]=min(dp[i-1][j]+t3,dp[i][temp]);
    }
    }
    res = -1;
    for (j = 0; j <= m; j++)
    res = min(res, dp[n][j]);
    printf("%u ", res);
    }
    }

  • 相关阅读:
    IndexDB
    实现es6中的set和map
    视口viewport
    nginx入门
    http协议
    图像格式
    promise
    js中this指向
    CSS 7阶层叠水平
    C# 一个方法如何返回多个值
  • 原文地址:https://www.cnblogs.com/fanyu1/p/12519413.html
Copyright © 2011-2022 走看看