zoukankan      html  css  js  c++  java
  • K

    Description

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.        
    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.        
             

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.        
                    

    Output

    For each integer in the input, output its digital root on a separate line of the output.        
                    

    Sample Input

    24
    39
    0
                    

    Sample Output

    6
    3
     
     
    用int 的话  会 结果错误!!
    #include<iostream>
    #include<cmath>
    using namespace std;
    void f(int a)
    {
        int s=0;
        for(int i=0;;i++){
            int t=pow((double)10,i);
            if(a/t==0)break;
            s+=a%(10*t)/t;
        }
        if(s/10!=0)f(s);
        else cout<<s<<endl;
    }
    int main()
    {
        int n;
        while(cin>>n){
            if(n==0)break;
            f(n);
        }
        return 0;
    }

    所以要用字符串!!

    #include<iostream>
    #include<string>
    #include<cmath>
    using namespace std;
    void g(int a)
    {
        int s=0;
        for(int i=0;;i++){
            int t=pow((double)10,i);
            if(a/t==0)break;
            s+=a%(10*t)/t;
        }
        if(s/10!=0)g(s);
        else cout<<s<<endl;
    }
    void f(string a)
    {
        int s=0,n=a.length();
        for(int i=0;i<n;i++){
            s+=a[i]-'0';
        }
        if(s/10!=0)g(s);
        else cout<<s<<endl;
    }
    int main()
    {
        string n;
        while(cin>>n){
            if(n=="0")break;
            f(n);
        }
        //system("pause");
        return 0;
    }
     
     
  • 相关阅读:
    [Oracle]如何为数据库设置Event(eg: ORA-00235)
    [Oracle]如何为数据库设置Event(eg: ORA-00235)
    C++常用字符串分割方法实例汇总
    C++常用字符串分割方法实例汇总
    C#学习笔记——常量、字段以及事件
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    混淆电路Garbled Circuit介绍
    安全计算实现方法概览
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5186716.html
Copyright © 2011-2022 走看看