zoukankan      html  css  js  c++  java
  • G

    Description

    T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.       

    Input

    On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.       

    Output

    For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.       

    Sample Input

    2
    1
    124866
    3
    124866
    111111
    987651
    

    Sample Output

    1
    8
    
    没看懂题意

    该题是求 各组数据取余不同 的最小数字

    #include<iostream>
    using namespace std;
    int cmp ( const void *a , const void *b )
    {
        return *(int *)a - *(int *)b;  
    }
    void f(int s[],int n)
    {
        int k,t,a[310];
        bool flag;
        for(t=1;;t++){
            flag=true;
            for(int i=0;i<n;i++){
                a[i]=s[i]%t;
            }
            qsort(a,n,sizeof(a[0]),cmp);
            for(int i=0;i<n-1;i++)
                if(a[i]==a[i+1]){
                    flag=false;
                    break;
                }
            if(flag==true)break;
        }
        cout<<t<<endl;
    }
    int main()
    {
        int n;
        cin>>n;
        while(n--){
            int g,s[310];
            cin>>g;
            for(int i=0;i<g;i++)cin>>s[i];
            if(g==1)cout<<1<<endl;
            else f(s,g);
        }
        //system("pause");
        return 0;
    }
  • 相关阅读:
    【转】Android开发中Handler的使用
    【转】关于微信开发者平台移动应用获取签名解决问题
    AndroidStudio开发工具快捷键
    进程与线程
    【转】Git常用命令
    Java中内存空间的分配及回收
    【转】Github入门教程
    周记
    本周工作内容及感想
    总结
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5186758.html
Copyright © 2011-2022 走看看