zoukankan      html  css  js  c++  java
  • E

    Description

    One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).        
    You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.        

    Input

    The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.      

    Output

    Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.      

    Sample Input

    10 6
    AACATGAAGG
    TTTTGGCCAA
    TTTGGCCAAA
    GATCAGATTT
    CCCGGGGGGA
    ATCGATGCAT

    Sample Output

    CCCGGGGGGA
    AACATGAAGG
    GATCAGATTT
    ATCGATGCAT
    TTTTGGCCAA
    TTTGGCCAAA


    该题 利用数组的技巧 巧算逆序数 如函数f所示
    运用结构体将 逆序数 与 字符串联系起来
    运用algorithm中的stable_sort函数 排序 相同时,不改变原有序列!!
    #include<iostream>
    #include<algorithm>
    using namespace std;
    struct DNA{
        char str[55];
        int num;
    }d[105];
    bool cmp(DNA a,DNA b)  
    {  
        return a.num<b.num;  
    }  
    int f(char s[],int n)
    {
        int a[5]={0,0,0,0},m=0;
        for(int i=n-1;i>=0;i--){
            switch(s[i]){
            case 'A':
                a[1]++;
                a[2]++;
                a[3]++;
                break;
            case 'C':
                a[2]++;
                a[3]++;
                m+=a[1];
                break;
            case 'G':
                a[3]++;
                m+=a[2];
                break;
            case 'T':
                m+=a[3];
                break;
            }
        }
        return m;
    }
    int main() {
        int n,m;
        cin>>n>>m;
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++)cin>>d[i].str[j];
            d[i].num=f(d[i].str,n);
        }
        stable_sort(d,d+m,cmp);
        for(int i=0;i<m;i++) {
            for(int j=0;j<n;j++)cout<<d[i].str[j];
            cout<<endl;
        }
        //system("pause");
        return 0;
    }
  • 相关阅读:
    Effective C# 原则37:使用标准的配置机制(译)
    Effective C# 原则31:选择小而简单的函数(译)
    Effective C# 原则24:选择申明式编程而不是命令式编程(译)
    Effective C# 原则34:创建大容量的Web API(译)
    Effective C# 原则27:避免使用ICloneable(译)
    Effective C# 第4章:创建基于二进制的组件(译)
    Effective C# 原则39:使用.Net验证(译)
    Effective C# 原则35:选择重写函数而不是使用事件句柄(译)
    Effective C# 原则25: 让你的类型支持序列化(译)
    Effective C# 原则38:使用和支持数据绑定(译)
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5208554.html
Copyright © 2011-2022 走看看