zoukankan      html  css  js  c++  java
  • poj 3959 Alignment of Code <vector>“字符串”

    Description

    You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc. For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

    Input

    The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

    Output

    Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.

    Sample Input

      start:  integer;    // begins here
    stop: integer; //  ends here  
     s:  string;   
    c:   char; // temp 

    Sample Output

    start: integer; // begins here
    stop:  integer; // ends   here
    s:     string;
    c:     char;    // temp


    代码超时!!!!!!!!!!!!!!!
    #include <iostream>
    #include <cstdio>
    #include <string>
    #include <vector>
    #include <sstream>
    using namespace std;
    
    vector<string> code[1000];      //1000行单词
    int len[110];
    int main()
    { 
        int n = 0;                            //len中存储一行中每个单词的长度
        string line;
        while((getline(cin,line)) != NULL){
    
            n++;
            stringstream ss(line);                //不用这个会累死的
    
            int q = 0;                            //q为每行单词第几个数
            string word;
            while(ss >> word){
                int t = word.length();
                if(n == 1)len[q] = t;
                else if(len[q] < t)len[q] = t;          //同一列单词中最长的
                q++;
                code[n].push_back(word);
            }
        } 
    
        for(int i = 0;i <= n;i++){
    
            int N = code[i].size();
            
            for(int j = 0;j < N;j++){
    
                line = code[i][j];
                int q = line.length();
                cout << code[i][j];
    
                for( int p = 0;p <= len[j] - q;p++)printf(" ");
            }
            putchar('
    ');
        }
    
       // system("pause");
        return 0;
    }


    n++的位置不对 导致插入向量的字符串存在问题

    #include <iostream>
    #include <cstdio>
    #include <string>
    #include <vector>
    #include <sstream>
    using namespace std;
    
    vector<string> code[1000];      //1000行单词
    int len[110];
    int main()
    { 
        int n = 0;                            //len中存储一行中每个单词的长度
        string line;
        while((getline(cin,line)) != NULL){
            stringstream ss(line);                //不用这个会累死的
            
            int q = 0;                            //q为每行单词第几个数
            string word;
            while(ss >> word){
                int t = word.length();
                if(n == 0)len[q] = t;
                else if(len[q] < t)len[q] = t;         //同一列单词中最长的
                q++;
                code[n].push_back(word);
            }
            n++;
        } 
        for(int i = 0;i < n;i++){
    
            int N = code[i].size();
            
            for(int j = 0;j < N;j++){
    
                line = code[i][j];
                int q = line.length();
                cout << code[i][j];
    
                for( int p = 0;p <= len[j] - q;p++)printf(" ");
            }
            putchar('
    ');
        }
    
       // system("pause");
        return 0;
    }

    补充几点

    在vector中查找特定的元素

    用 find 函数,头文件#include <algorithm>

    vector<int> x;
     x.push_back(123);
     x.push_back(333);
     x.push_back(222);
     vector<int>::iterator iter;
     iter = find(x.begin(), x.end(), 222);

    清空vector

    vector<int>student;
    student.clear();
  • 相关阅读:
    QTdebug时没有调试引擎
    快速排序
    MFC之动态创建按钮
    Linux 本人常用到的基本命令
    history 查看历史操作记录在shell脚本执行中无法显示问题
    C#基础学习5
    C#基础学习4
    C#基础学习3
    C#基础学习1
    C#基础学习2
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5459462.html
Copyright © 2011-2022 走看看