zoukankan      html  css  js  c++  java
  • uva 10763 Foreign Exchange <"map" ,vector>

    Foreign Exchange

    Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task.

    The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

    Input

    The input file contains multiple cases. Each test case will consist of a line containing n - the number of candidates (1≤n≤500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate's original location and the candidate's target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

    Output

    For each test case, print "YES" on a single line if there is a way for the exchange program to work out, otherwise print "NO".

    Sample Input 

    10

    1 2

    2 1

    3 4

    4 3

    100 200

    200 100

    57 2

    2 57

    1 2

    2 1

    10

    1 2

    3 4

    5 6

    7 8

    9 10

    11 12

    13 14

    15 16

    17 18

    19 20

    0

     Sample Output 

    YES

    NO

    用map写,写了一大截才发现不可以用map的,因为 map不可以存储相同的键值,这是用map写了一半的代码

    #include <cstdio>
    #include <iostream>
    #include <map>
    using namespace std;
    
    map<int,int> students;
    map<int,int>::iterator t, pos1, pos2;
    
    int main()
    {
        int T;
        while(scanf("%d",&T) == 1){
            if(T == 0)break;
            int a,b;
    
            for(int i = 0; i < T; i++){
                scanf("%d%d",&a,&b);
                students[a]=b;
            }
    
            int n = students.size(), i = 0;
    
            for(t = students.begin(); i < n; t++, i++){
    
                cout<<"begin-----------------------"<<endl;
                if((*t).second == 0)continue;
    
                if(students[(*t).second] == NULL){
                    cout<<(*t).second<<" "<<students[(*t).second]<<endl;
                    cout<<"NO"<<endl;
                    break;
                }
    
                else{
    
                    a = students[(*t).second];
                    cout<<a<<" ++ "<<students[a]<<" -- "<<(*t).first<<endl;
    
                    if(a == (*t).first){
                        //cout<<"111  "<<(*t).second<<endl;
                        
                        pos1 = students.find((*t).second);
                        pos2 = students.find((*t).first);
                        (*pos1).second = 0;
                        (*pos2).second = 0;
    
                        //cout<<"222  "<<(*t).first<<endl;
                    }
                }
    
            }
    
            if(students.empty())cout<<"YES"<<endl;
            
    
    
        }
        //system("pause");
        return 0;
    }


    用vector做即可

    #include <cstdio>
    #include <iostream>
    #include <vector>
    using namespace std;
    
    vector<int>student1;
    vector<int>student2;
    
    int main()
    {
        int T;
        while(scanf("%d",&T) == 1){
            if(T == 0)break;
    
            student1.clear();
            student2.clear();
    
            int a,b;
    
            for(int i = 0;i < T; i++){
                cin>>a>>b;
                student1.push_back(a);
                student2.push_back(b);
            }
    
            for(int i = 0;i < T; i++){
    
                if(student1[i] == 0)continue;
                
                for(int j = i+1;j <T; j++){
    
                    if(student2[j] == 0)continue;
    
                    if(student1[i] == student2[j]){ 
    
                        if(student2[i] == student1[j])student1[i] = student1[j] = student2[i] = student2[j] = 0;
                        else{
                            student2[j] = student2[i];
                            student1[i] = student2[i] = 0;
                        }
                    }
                }
            }
    
    
            int k = 1;
    
            for(int i = 0;i < T; i++){
                if(student1[i] != 0&&student2[i] != 0){
                    k = 0;
                    break;
                }
            }
    
            if(k)cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
    
        }
        //system("pause");
        return 0;
    }
  • 相关阅读:
    【PBR的基本配置】
    【super vlan的配置】
    Day_03-函数和模块的使用
    Day_02-Python的循环结构
    Day_02-Python的分支结构和循环结构
    Day01_课后练习题
    Day01_初识Python
    一、Linux知识体系结构图
    NAND Flash结构及驱动函数
    区分大端和小端
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5460717.html
Copyright © 2011-2022 走看看