zoukankan      html  css  js  c++  java
  • 112Tree Summing

     Tree Summing 

    Background

    LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, which are the fundamental data structures in LISP, can easily be adapted to represent other important data structures such as trees.

    This problem deals with determining whether binary trees represented as LISP S-expressions possess a certain property.

    The Problem

    Given a binary tree of integers, you are to write a program that determines whether there exists a root-to-leaf path whose nodes sum to a specified integer. For example, in the tree shown below there are exactly four root-to-leaf paths. The sums of the paths are 27, 22, 26, and 18.

    picture25

    Binary trees are represented in the input file as LISP S-expressions having the following form.

     
    empty tree 		 ::= 		 ()

    tree ::= empty tree tex2html_wrap_inline118 (integer tree tree)

    The tree diagrammed above is represented by the expression (5 (4 (11 (7 () ()) (2 () ()) ) ()) (8 (13 () ()) (4 () (1 () ()) ) ) )

    Note that with this formulation all leaves of a tree are of the form (integer () () )

    Since an empty tree has no root-to-leaf paths, any query as to whether a path exists whose sum is a specified integer in an empty tree must be answered negatively.

    The Input

    The input consists of a sequence of test cases in the form of integer/tree pairs. Each test case consists of an integer followed by one or more spaces followed by a binary tree formatted as an S-expression as described above. All binary tree S-expressions will be valid, but expressions may be spread over several lines and may contain spaces. There will be one or more test cases in an input file, and input is terminated by end-of-file.

    The Output

    There should be one line of output for each test case (integer/tree pair) in the input file. For each pairI,T (I represents the integer, T represents the tree) the output is the string yes if there is a root-to-leaf path in T whose sum is I and no if there is no path in T whose sum is I.

    Sample Input

    22 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
    20 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
    10 (3 
         (2 (4 () () )
            (8 () () ) )
         (1 (6 () () )
            (4 () () ) ) )
    5 ()

    Sample Output

    yes
    no
    yes
    no
    //看完lhshaoren的解题报告。。再自己写了一遍。。算是我做(抄袭)的第一道二叉树题目吧。
    #include <iostream>
    #include <fstream>
    using namespace std;
    ifstream fin("test.txt");
    #define cin fin                //提交的时候忘了注释掉这2行,囧~
    bool ok;
    bool tree_sum(int sum,int n)
    {
        int v;
        char ch;
        cin >> ch;
        if(cin >> v)
        {
            sum += v;
            bool t;
            t = tree_sum(sum,n) | tree_sum(sum,n);  //如果没有子节点,则t为false;否则为true 
            if(!ok && !t) 
            ok = (sum == n);
            cin >> ch;
            return true;
        }
        else
        {
            cin.clear();
            cin >> ch;
            return false;
        }
    }
    int main()
    {
        int n;
        while(cin >> n)
        {
            ok = false;
            tree_sum(0,n);
            cout << (ok ? "yes\n" : "no\n");
        }
        return 0;
    }
  • 相关阅读:
    第四章 变量的三大特征,垃圾回收机制,可变类型和不可变类型的简单表述
    第三章 有关变量的理解
    第二章 编程语言的分类及优缺点的分析
    IIS拓展访问的文件格式
    JS之HTTP请求
    HTTP请求
    HtmlAgilityPack解析html
    支付宝支付功能开发
    Web.config配置ActiveReports
    数据库连接字符串
  • 原文地址:https://www.cnblogs.com/fchx/p/2876897.html
Copyright © 2011-2022 走看看