zoukankan      html  css  js  c++  java
  • POJ3903:Stock Exchange(LIS)

    题目链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=87125#problem/E

    题目:

    Description

    The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

    Input

    Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
    White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output

    The program prints the length of the longest rising trend. 
    For each set of data the program prints the result to the standard output from the beginning of a line.

    Sample Input

    6 
    5 2 1 4 5 3 
    3  
    1 1 1 
    4 
    4 3 2 1

    Sample Output

    3 
    1 
    1

    Hint

    There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
     
     
    题意:
       一道LIS的裸题,给定一组数据,让我们求出这组数据的最大上升的序列包含元素的个数。
    思路:
        要注意数据比较多,要用二分法的优化法(O(nlogn))。
     
      
    #include<iostream>
      #include<cstdio>
      using namespace std;
      const int maxn=100001;
      int a[maxn],b[maxn];
      int main()
      {  
          int n,i,L,mid;
         while(scanf("%d",&n)!=EOF)
         {
            a[0]=-1;
             int count=0;
            int  Max=0;
          for(i=1;i<=n;i++)
              cin>>a[i];
          for(i=1;i<=n;i++)
          {
            if(a[i]>b[count]) 
                b[++count]=a[i];
          else 
          {
             Max=count;
             L=1;
           while(L<=Max)
           {
             mid=(L+Max)/2;
             if(b[mid]<a[i])
                 L=mid+1;
             else Max=mid-1;
           }
            b[L]=a[i];
          }
          }
          cout<<count<<endl;
         }
         return 0;
     }
  • 相关阅读:
    spring异常处理器
    热部署环境下,dubbo序列化的bug和优化
    函数式编程的一些魅力
    常用的jvm命令
    JS直接访问WebService(来自于网络)
    AjaxControlToolkit使用报错
    Server Application Unavailable
    ScriptManager调用WebService注意事项
    SNK签名文件添加
    vs无法调试,启动后类似于ctrl+F5
  • 原文地址:https://www.cnblogs.com/fenhong/p/4732644.html
Copyright © 2011-2022 走看看