zoukankan      html  css  js  c++  java
  • POJ 3903:Stock Exchange(裸LIS + 二分优化)

    http://poj.org/problem?id=3903

    Stock Exchange
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5983   Accepted: 2096

    Description

    The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

    Input

    Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).  White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output

    The program prints the length of the longest rising trend.  For each set of data the program prints the result to the standard output from the beginning of a line.

    Sample Input

    6 
    5 2 1 4 5 3 
    3  
    1 1 1 
    4 
    4 3 2 1

    Sample Output

    3 
    1 
    1

    Hint

    There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
     
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    #include<iostream>
    #include <string>
    #include <cmath>
    using namespace std;
    //LIS+二分优化  O(nlogn)
    //参考:http://www.cnblogs.com/ziyi--caolu/p/3227121.html
    int a[100005];
    
    int main()
    {
        int n;
        while(cin>>n){
            int k=1,in;
            scanf("%d",a+1);
            for(int i=2;i<=n;i++){
                scanf("%d",&in);
                if(in>a[k]) a[++k]=in;
                else{
                    int l=1,r=k,mid;
                    while(l<r){
                        mid=(l+r)/2;
                        if(a[mid]<in) l=mid+1;
                        else r=mid;
                    }
                    a[l]=in;
                }
            }
            cout<<k<<endl;
        }
        return 0;
    }

     

    2016-05-29

  • 相关阅读:
    抽象类
    继承
    面向对象的静态属性,类方法,静态方法
    查找linux系统下的端口被占用进程的两种方法 【转】
    awk学习
    【转】借助LVS+Keepalived实现负载均衡
    ORA-28001: the password has expired解决方法
    ORACLE的还原表空间UNDO写满磁盘空间,解决该问题的具体步骤
    Oracle控制文件多路复用以及Oracle备份重建控制文件
    RedHat6.1通过配置yum server安装软件包
  • 原文地址:https://www.cnblogs.com/fightfordream/p/5558696.html
Copyright © 2011-2022 走看看