zoukankan      html  css  js  c++  java
  • POJ 3903:Stock Exchange(裸LIS + 二分优化)

    http://poj.org/problem?id=3903

    Stock Exchange
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5983   Accepted: 2096

    Description

    The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

    Input

    Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).  White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output

    The program prints the length of the longest rising trend.  For each set of data the program prints the result to the standard output from the beginning of a line.

    Sample Input

    6 
    5 2 1 4 5 3 
    3  
    1 1 1 
    4 
    4 3 2 1

    Sample Output

    3 
    1 
    1

    Hint

    There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
     
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    #include<iostream>
    #include <string>
    #include <cmath>
    using namespace std;
    //LIS+二分优化  O(nlogn)
    //参考:http://www.cnblogs.com/ziyi--caolu/p/3227121.html
    int a[100005];
    
    int main()
    {
        int n;
        while(cin>>n){
            int k=1,in;
            scanf("%d",a+1);
            for(int i=2;i<=n;i++){
                scanf("%d",&in);
                if(in>a[k]) a[++k]=in;
                else{
                    int l=1,r=k,mid;
                    while(l<r){
                        mid=(l+r)/2;
                        if(a[mid]<in) l=mid+1;
                        else r=mid;
                    }
                    a[l]=in;
                }
            }
            cout<<k<<endl;
        }
        return 0;
    }

     

    2016-05-29

  • 相关阅读:
    react-router-dom中的BrowserRouter和HashRouter,link与Navlink
    在React中使用react-router-dom路由
    详解react中的state,props,refs
    简单明了的vuex详解
    暂时性死区
    es6中的块级作用域
    es6的let
    前端模块化
    Web框架
    百分比布局 双飞翼布局 圣杯布局
  • 原文地址:https://www.cnblogs.com/fightfordream/p/5558696.html
Copyright © 2011-2022 走看看