zoukankan      html  css  js  c++  java
  • 北大ACM 1008题—Maya Calendar

    Maya Calendar
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 58623   Accepted: 18070

    Description

    During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor. 

    For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles. 

    Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows: 

    1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . . 

    Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was: 

    Haab: 0. pop 0 

    Tzolkin: 1 imix 0 
    Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar. 

    Input

    The date in Haab is given in the following format: 
    NumberOfTheDay. Month Year 

    The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000. 

    Output

    The date in Tzolkin should be in the following format: 
    Number NameOfTheDay Year 

    The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates. 

    Sample Input

    3
    10. zac 0
    0. pop 0
    10. zac 1995

    Sample Output

    3
    3 chuen 0
    1 imix 0
    9 cimi 2801

    Source

    #include <iostream>
    #include <string>
    using namespace std;
    
    char Haab_month[19][10]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol",
    	"chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
    char Tzolkin_month[20][10]={"imix","ik","akbal","kan","chicchan","cimi","manik",
    	"lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
    
    int main()
    {
    	int n,year,day,mon,t;
    	char s[10];
    	cin>>n;
    	cout<<n<<endl;
    	while(n--)
    	{
    		cin>>day;
    		getchar();//skip the dot
    		getchar();//skip the enter
    		//scanf("%d. %s %d",&day,s,&year);or we could use this statement to skip the dot
    		cin>>s>>year;
    		for(mon=0;mon<19;mon++)
    			if(strcmp(Haab_month[mon],s)==0)
    				break;
    		t=365*year+mon*20+day;//Haab is counted from 0 day,the statement is 
            //to sum the wholl days
    		cout<<1+t%13<<" "<<Tzolkin_month[t%20]<<" "<<t/260<<endl;//first one is begun with 1
    	}
    	return 0;
    }


  • 相关阅读:
    Yii2 urles
    mpdf Could not find image file (http://local.com/xxxxx)
    如何 安装Yii2的高级应用程序模板
    yii2的GridView和ActiveDataProvider具体使用
    Yii2的框架笔记整理
    笔记
    phpstudy本地搭建域名访问
    phpstrom的xdebug开启和yii2下的分页的链接
    一些自己编写的简单的js
    几种经过整理的文件上传压缩和前台js压缩的方法
  • 原文地址:https://www.cnblogs.com/finlay/p/3234725.html
Copyright © 2011-2022 走看看