zoukankan      html  css  js  c++  java
  • 【POJ 3176】Cow Bowling(DP)

    Description

    The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

     7 

    3 8

    8 1 0

    2 7 4 4

    4 5 2 6 5
    Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

    Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

    Input

    Line 1: A single integer, N 

    Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

    Output

    Line 1: The largest sum achievable using the traversal rules

    Sample Input

    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    Hint

    Explanation of the sample: 

     7 
    *
    3 8
    *
    8 1 0
    *
    2 7 4 4
    *
    4 5 2 6 5
    The highest score is achievable by traversing the cows as shown above.
    题意:每次向下或者向右下走,求最大和
    分析:正向:每步来源于上方或者左上方,dp[i][j]表示第i行第j列的最大值
    dp[i][j]=max{dp[i-1][j],dp[i-1][j-1]}+a[i][j].
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    int n,a[355][355],ans[355][355],maxans;
    int main(){
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=i;j++)
                scanf("%d",&a[i][j]);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=i;j++){
                ans[i][j]=max(ans[i-1][j],ans[i-1][j-1])+a[i][j];
                maxans=max(ans[i][j],maxans);
            }
        }
        printf("%d",maxans);
        return 0;
    }
    逆向:逆着从n-1行到第1行,每次比较下方和右下方的大小,大的加上去,最后输出a[1][1]即可。
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    int n,i,j,a[355][355];
    int main(){
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            for(j=1;j<=i;j++)
                scanf("%d",&a[i][j]);
        for(i=n-1;i>=1;i--)
            for(j=1;j<=i;j++)
                a[i][j]+=max(a[i+1][j],a[i+1][j+1]);
        printf("%d",a[1][1]);
        return 0;
    }
  • 相关阅读:
    java ssl https 连接详解 生成证书
    mysql实战优化之四:mysql索引优化
    mysql实战优化之五: 更新/插入优化 sql优化
    mysql实战优化之六:Order by优化 sql优化、索引优化
    mina2中IoHandler
    I/O通信模型(BIO,NIO,AIO)
    mina框架详解
    转:架构师于小波:魅族实时消息推送架构
    支付业务的数据库表的设计
    实战 TestNG 监听器
  • 原文地址:https://www.cnblogs.com/flipped/p/5183192.html
Copyright © 2011-2022 走看看