zoukankan      html  css  js  c++  java
  • zoj 2850 Beautiful Meadow

    ZOJ Problem Set - 2850
    Beautiful Meadow

    Time Limit: 1 Second      Memory Limit: 32768 KB


    Tom's Meadow

    Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

    1. Not all squares are covered with grass.
    2. No two mowed squares are adjacent.

    Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

    Input

    The input contains multiple test cases!

    Each test case starts with a line containing two integers N, M (1 <= N, M <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

    A line with N = 0 and M = 0 signals the end of the input, which should not be processed

    Output

    One line for each test case.

    Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

    Sample Input

    2 2
    1 0
    0 1
    2 2
    1 1
    0 0
    2 3
    1 1 1
    1 1 1
    0 0

    Sample Output

    Yes
    No
    No

    Author: CAO, Peng


    Source: Zhejiang Provincial Programming Contest 2007
    Submit    Status
    //1859941 2009-05-08 14:40:12 Accepted  2850 C++ 0 184 Wpl
    //1859935 2009-05-08 14:29:21 Wrong Answer  2850 C++ 0 184 Wpl  
    #include <iostream>
    #define MAX 12
    using namespace std;
    int map[MAX][MAX];
    int a[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
    int n,m,sum;
    bool mark;
    void Init()
    {
        
    int i,j;
        
    for(i=0;i<n;i++)
            
    for(j=0;j<m;j++)
                scanf(
    "%d",&map[i][j]);
    }
    bool Bound(int x,int y)
    {
        
    if(x>=0&&y>=0&&x<n&&y<m)
            
    return true;
        
    else
            
    return false;
    }
    void Decide()
    {
        
    int i,j,ti,tj,k;
        
    for(i=0;i<n;i++)
            
    for(j=0;j<m;j++)
            {
                
    if(map[i][j]==1)
                {
                    sum
    ++;
                    
    continue;
                }
                
    for(k=0;k<4;k++)
                {
                    ti
    =i+a[k][0];  //此处小心,绝不能写成i或者k,这里错过两次了
                    tj=j+a[k][1];
                    
    if(Bound(ti,tj))
                    {
                        
    if(map[ti][tj]==0)
                        {
                            mark
    =true;
                            
    return ;
                        }
                    }
                }
            }
    }
    int main()
    {
        
    while(scanf("%d%d",&n,&m)!=EOF)
        {
            
    if(n==0&&m==0)
                
    break;
            Init();
            mark
    =false;
            sum
    =0;
            Decide();
            
    if(mark||sum==m*n)
                printf(
    "No\n");
            
    else
                printf(
    "Yes\n");
        }
        
    return 0;
    }
  • 相关阅读:
    iOS-runtime-根据协议名调某一个类有与协议里面放的相同的方法
    Mac下显示隐藏文件
    OC开发_整理笔记——多线程之GCD
    兵器簿之cocoaPods的安装和使用
    手写代码UI,xib和StoryBoard间的的优劣比较
    OC开发_Storyboard——MapKit
    smartFloat
    固定浮动侧边栏(SmartFloat)
    一个模拟时钟的时间选择器 ClockPicker
    分布式事务TransactionScope
  • 原文地址:https://www.cnblogs.com/forever4444/p/1452640.html
Copyright © 2011-2022 走看看