zoukankan      html  css  js  c++  java
  • zoj 2105 Number Sequence

    ZOJ Problem Set - 2105

    Number Sequence

    Time Limit: 1 Second      Memory Limit: 32768 KB

    A number sequence is defined as follows:

    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

    Given A, B, and n, you are to calculate the value of f(n).


    Input

    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


    Output

    For each test case, print the value of f(n) on a single line.


    Sample Input

    1 1 3
    1 2 10
    0 0 0


    Sample Output

    2
    5


    Author: CHEN, Shunbao


    Source: Zhejiang Provincial Programming Contest 2004
    Submit    Status
    //1385524 2008-03-29 22:34:43 Accepted  2105 C++ 0 832 Wpl 
    #include <iostream>
    using namespace std;
    int main()
    {
        
    int a,b,d;
        
    long n;
        
    int arry[49];
        arry[
    1]=1;
        arry[
    2]=1;
        cin
    >>a>>b>>n;
        
    while(a!=0&&b!=0&&n!=0)
        {
            
    for(d=3;d<=48;d++)
                arry[d]
    =(arry[d-1]*a%7+arry[d-2]*b%7)%7;
            cout
    <<arry[(n-1)%48+1]<<endl;            
            cin
    >>a>>b>>n;
        }
    }
  • 相关阅读:
    Oracle和MySQL的对比
    mysql的默认隔离级别
    mysql数据库中锁机制的详细介绍
    什么电影是好电影
    周记 2019.4.8~4.14
    周记 2019.3.25~2019.3.31
    IntelliJ Idea 使用笔记
    笔记
    kafka总结
    Spring boot
  • 原文地址:https://www.cnblogs.com/forever4444/p/1453166.html
Copyright © 2011-2022 走看看