ZOJ Problem Set - 2417
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
Output
For each A in the input, output a line containing only its lowest bit.
Sample Input
26
88
0
Sample Output
2
8
Author: SHI, Xiaohan
Source: Zhejiang University Local Contest 2005
#include<iostream>
#include <cmath>
using namespace std;
int main()
{
int n , h;
while (cin >> n)
{
if (n == 0)
break;
int j = 0;
while (n % 2 == 0)
{
n /= 2;
j ++;
}
h = pow (2.0 , j);
cout << h << endl;
}
return 0;
}
#include <cmath>
using namespace std;
int main()
{
int n , h;
while (cin >> n)
{
if (n == 0)
break;
int j = 0;
while (n % 2 == 0)
{
n /= 2;
j ++;
}
h = pow (2.0 , j);
cout << h << endl;
}
return 0;
}