zoukankan      html  css  js  c++  java
  • POJ 3125 Printer Queue(打印队列)

    题目链接: http://poj.org/problem?id=3125

    2012年8月7日,暑假组队后个人训练赛第一场


    Printer Queue
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3082   Accepted: 1655

    Description

    The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

    Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
    and 1 being the lowest), and the printer operates as follows.
    • The first job J in queue is taken from the queue.
    • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
    • Otherwise, print job J (and do not put it back in the queue).
    In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

    Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

    Input

    One line with a positive integer: the number of test cases (at most 100). Then for each test case:
    • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
    • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

    Output

    For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

    Sample Input

    3
    1 0
    5
    4 2
    1 2 3 4
    6 0
    1 1 9 1 1 1

    Sample Output

    1
    2
    5

    Source

    因为我现在还不会队列,所以就看的我学姐模拟的一个队列的代码:
    /*
    思路(yf):
    这个题思路很简单,就是运用的队列,主要是处理时费时间。要想清楚才行,
    比如说,第一个,从队列的front 看来是找到rear,如是没有比他大的就直接打印,time +=1;
    判断这个点是不是标记的那个点,如果是,则直接输出time ,如果不是就向后走,
    还有需要注意的就是,如果是找到那个要打印的那个点,如果不能打印,
    那么这个标记打印的数也要跟着变化,
    主要就这两点吧
    代码:
    */
    #include<iostream>
    #include<stdio.h>
    using namespace std;
    int main()
    {
        int a[10010];
        int front,rear,i;
        int cases,n,d,time,ok;
        scanf("%d",&cases);
        while(cases--)
        {
            front=0;rear=0;time=0;ok=0;
            scanf("%d%d",&n,&d);
            for(i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                rear++;
            }
            while(front<=rear)
            {
                for(i=front;i<rear;i++)
                {
                    if(a[i]>a[front]) 
                    {
                        a[rear++]=a[front];
                        break;
                    }
                }
                
                if(i>=rear) 
                {
                    time+=1;
                    if(front==d)
                    {
                        printf("%d\n",time);
                        ok=1;
                        break;
                    }
                    else 
                        front++;
                }
                else if(front==d) {d=rear-1;} 
                else front++;
                if(ok) break;
            }
        }
        return 0;
    }
  • 相关阅读:
    Java二维数组
    Java实现冒泡排序
    python类简记
    LaTeX:论文Instruction最后一段的章节引用
    在Adobe IIIustator中加入数学公式——配合MathType使用
    org.springframework.web.bind.annotation不存在
    xshell5 下载安装
    MultipartFile解析Excel
    开源项目环境搭建
    学习路线
  • 原文地址:https://www.cnblogs.com/freezhan/p/2638865.html
Copyright © 2011-2022 走看看