zoukankan      html  css  js  c++  java
  • hdu 1114 PiggyBank(完全背包)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114

    Piggy-Bank

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5450    Accepted Submission(s): 2714

    Problem Description
    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
     
    Input
    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
     
    Output
    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
     
    Sample Input
    3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
     
    Sample Output
    The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
     
    Source
     
    Recommend
    Eddy

    完全背包问题,不会做啊!!!

    题目大意:称出背包装物品前后的重量,求最小价值。

    下面先贴个kb神的代码,感谢强大的kb神。。。源代码来自 http://www.cnblogs.com/kuangbin/archive/2011/08/04/2127887.html by kb神

    #include<stdio.h>
    #include<string.h>
    #define INF 0x7ffffff
    #define MAXN 10000
    int dp[MAXN+10];//dp[i]表容量为i的时候所装东西的最小价值
    int main()
    {
        int w1,w2;
        int P,W;
        int T,n;
        int i,j;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&w1,&w2);
            scanf("%d",&n);
            for(i=1;i<=w2-w1;i++)
               dp[i]=INF;//初始化为无穷大
            dp[0]=0;
            while(n--)
            {
                scanf("%d%d",&P,&W);
                for(i=W;i<=w2-w1;i++)
                    if(dp[i]>dp[i-W]+P)
                       dp[i]=dp[i-W]+P;
            }
            if(dp[w2-w1]==INF) printf("This is impossible.\n");
            else
               printf("The minimum amount of money in the piggy-bank is %d.\n",dp[w2-w1]);     
        }    
        return 0;
    }

    下面再贴个思路一样但是,写的比较常规的代码(一般的模板什么的,貌似都是这样用数组写的)

    //AC 93ms 292k 15kb (by C++)
    #include<stdio.h>
    #include<string.h>
    
    int p[505],w[505];
    int dp[10005];
    
    int min(int a,int b)
    {
        return a < b ? a : b ;
    }
     
    int main()
    {
        int test;
        int empty,full;
        int n;
        int i,j,k;
        scanf("%d",&test);
        while(test--)
        {
            scanf("%d%d",&empty,&full);
            scanf("%d",&n);
            for(i=1;i<=n;i++)
                scanf("%d%d",&p[i],&w[i]);
            memset(dp,1,sizeof(dp));
            dp[0]=0;
            for(i=1;i<=n;i++)
                 for(j=w[i];j<=full-empty;j++) 
                       dp[j]=min(dp[j],dp[j-w[i]]+p[i]); 
            if(dp[full-empty]==16843009)
               printf("This is impossible.\n");
            else
               printf("The minimum amount of money in the piggy-bank is %d.\n",dp[full-empty]);        
        }
        return 0;
    }


  • 相关阅读:
    MySQL_01 常用命令
    32_Go基础(TCP通信)
    oracle查询优化
    Eclipse中自动添加注释(作者,时间)
    java注解的学习
    JqueryeasyUIdatagrid参数之 queryParams
    Eclipse中,打开文件所在文件夹的插件,及设置
    更改Zend Studio/Eclipse代码风格主题
    JAVA中使用File类批量重命名文件及java.io.File的常见用法
    java面试笔试题大全
  • 原文地址:https://www.cnblogs.com/freezhan/p/2638871.html
Copyright © 2011-2022 走看看