zoukankan      html  css  js  c++  java
  • POJ 2109 Power of Cryptography

    不知道那里贪心了。。。学长说贪心。

    注意:数据类型范围,还是不太了解;

    原题链接:http://poj.org/problem?id=2109

    Power of Cryptography
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 13983   Accepted: 7136

    Description

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
    This problem involves the efficient computation of integer roots of numbers. 
    Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

    Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

    Output

    For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

    Sample Input

    2 16
    3 27
    7 4357186184021382204544

    Sample Output

    4
    3
    1234

    Source

    各种数据类型范围:

    unsigned   int   0~4294967295   
    int   2147483648~2147483647 
    unsigned long 0~4294967295
    long   2147483648~2147483647
    long long的最大值:9223372036854775807
    long long的最小值:-9223372036854775808
    unsigned long long的最大值:1844674407370955161

    __int64的最大值:9223372036854775807
    __int64的最小值:-9223372036854775808
    unsigned __int64的最大值:18446744073709551615


    //Accepted	212K	0MS	C++	212B	2012-09-18 20:47:04
    #include<cstdio>
    #include<cmath>
    int main()
    {
        double n,p;
        double ans;
        while(scanf("%lf%lf",&n,&p)!=EOF)
        {
            ans=pow(p,1/n);
            printf("%.0lf\n",ans);
        }
        return 0;
    }


  • 相关阅读:
    spring获取webapplicationcontext,applicationcontext几种方法详解(转)
    spring注入是否会被回收
    think in java 手记(一)
    spring 注解实例
    navicat远程连接oracle
    tomcat监听activemq jms配置
    HDU 1160:FatMouse's Speed
    YTU 2457: 很简单的一道题
    YTU 2456: 评委打分
    YTU 2455: Pefect 数字
  • 原文地址:https://www.cnblogs.com/freezhan/p/2776479.html
Copyright © 2011-2022 走看看