zoukankan      html  css  js  c++  java
  • POJ 3280 Cheapest Palindrome【DP之经典回文问题】

    原题链接:http://poj.org/problem?id=3280

    CSUST:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=20437#problem/C

    转载来自:http://blog.sina.com.cn/s/articlelist_1836701754_0_1.html

    Cheapest Palindrome
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 4305   Accepted: 2091

    Description

    Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

    Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

    FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

    Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

    Input

    Line 1: Two space-separated integers: N and M 
    Line 2: This line contains exactly M characters which constitute the initial ID string 
    Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

    Output

    Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

    Sample Input

    3 4
    abcb
    a 1000 1100
    b 350 700
    c 200 800

    Sample Output

    900

    Hint

    If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

    Source

    推荐先看前一篇POJ 1159的博文点击打开链接

    题意给你一串字符,通过添加删除其中的一部分,使其变成一个回文串,并且花费最小(添加删除都有权值)。

     

    分析:经典DP。是poj1159的加强版本,增加了删除操作,而且每次插入删除的代价也不一定为一个恒定值,但是大体上的思路是一样的:设dp[i][j]表示将i--j变成回文串的最小代价。

    插入操作在我的上上篇博文有讲,这里不再多赘述。

    删除操作的状态很好表示:f(i,j-1)+ 删除第j个字符的代价  

                                              f(i+1,j)+删除第i个字符的代价

     

    代码(454ms AC):

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <algorithm>
    #include <string>
    #include <map>
    using namespace std;
    int len,letter,dp[2105][2105];
    map <char,int> insert,removed;
    char str[2105];
    int DFS(int l,int r){
       if(l>=r)
        return 0;
       if(dp[l][r]!=-1)
        return dp[l][r];
       int M=99999999;
       if(str[l]==str[r])
         M=DFS(l+1,r-1);
       else{
         M=min(M,DFS(l+1,r)+insert[str[l]]);
         M=min(M,DFS(l,r-1)+insert[str[r]]);
         M=min(M,DFS(l+1,r)+removed[str[l]]);
         M=min(M,DFS(l,r-1)+removed[str[r]]);
       }
       return dp[l][r]=M;
    }
    int main()
    {
       while(scanf("%d %d",&letter,&len)!=EOF){
          memset(dp,-1,sizeof(dp));
          scanf("%s",str+1);
          insert.clear();
          removed.clear();
          for(int i=1;i<=letter;i++){
             getchar();
             char ch;
             int i,r;
             scanf("%c %d %d",&ch,&i,&r);
             insert[ch]=i,removed[ch]=r;
          }
          cout<<DFS(1,len)<<endl;
       }
       return 0;
    }

    一样Orz

    //Accepted	16004K	594MS	C++	947B	2013-03-15 20:09:34
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<algorithm>
    using namespace std;
    
    const int maxn =  2000 + 5;
    int dp[maxn][maxn];
    map<char, int> add , delet;
    char str[maxn];
    
    int dfs(int l, int r)
    {
    	if(l >= r) return 0;
    	else if(dp[l][r] != -1) return dp[l][r];
    	
    	int M1,M2;
    	if(str[l] == str[r]) M1 = dfs(l+1, r-1);
    	else
    	{
    		M1 = min(dfs(l+1,r)+add[str[l]], dfs(l, r-1)+add[str[r]]);
    		M2 = min(dfs(l+1, r)+delet[str[l]], dfs(l, r-1)+delet[str[r]]);
    		M1 = min(M1, M2);
    	}
     
    	return dp[l][r] = M1;
    }
    int main()
    {
    	int n, m;
    	while(scanf("%d%d", &n, &m) != EOF)
    	{
    		memset(str, '0', sizeof(str));
    		memset(dp, -1, sizeof(dp));
    		add.clear();
    		delet.clear();
    		
    		scanf("%s", str+1);
    		char ch;
    		int ad, del; 
    		for(int i = 1; i <= n; i++)
    		{
    			getchar();
    			scanf("%c%d%d", &ch, &ad, &del);
    			add[ch] = ad;
    			delet[ch] = del;
    		}
    		
    		printf("%d\n", dfs(1,m));
    	}
    	return 0;
    }


  • 相关阅读:
    C语言学习之我见-strcpy()字符串复制函数
    豆邮windows客户端(第三方)开发详解
    项目管理的主要控制因素(转)
    daterangepicker -- bootstrap日期时间范围插件使用分享
    Jacob
    Selenium
    基本套接字总结(@function)
    Python字符串处理NoneType的处理
    机器学习相关会议(转载)
    jboss-AS目录结构了解(资料摘取)
  • 原文地址:https://www.cnblogs.com/freezhan/p/2974230.html
Copyright © 2011-2022 走看看