zoukankan      html  css  js  c++  java
  • POJ 1573 && hdu 1035 Robot Motion【简单模拟】

    题目链接:http://poj.org/problem?id=1573

                       http://acm.hdu.edu.cn/showproblem.php?pid=1035

    Robot Motion

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3893    Accepted Submission(s): 1817


    Problem Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page)
    S south (down the page)
    E east (to the right on the page)
    W west (to the left on the page)

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
     

    Input
    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
     

    Output
    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
     

    Sample Input
    3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
     

    Sample Output
    10 step(s) to exit 3 step(s) before a loop of 8 step(s)
     

    Source
     
    感谢kb神的推荐~~~~~~

    //AC 168kb 0ms POJ1573 C++ 
    //AC  256kb 0ms hdu 1035 C++
    #include<stdio.h>
    #include<string.h>
    
    char map[15][15];
    int dis[15][15];
    
    int main()
    {
    	int n,m,s;
    	int i,j;
    	int si,sj;
    	int step;
    	int step1;
    	while(scanf("%d%d%d%*c",&n,&m,&s)!=EOF && m)
    	{
    		step=0;step1=0;
    		memset(dis,0,sizeof(dis));
    		for(i=1;i<=n;i++)
    		{
    			for(j=1;j<=m;j++)
    				scanf("%c",&map[i][j]);
    			getchar();
    		}
    		si=1;sj=s;
    		while(si>=1 && si<=n && sj>=1 && sj<=m &&!dis[si][sj])
    		{
    			step++;
    			dis[si][sj]=1;
    			if(map[si][sj]=='W')
    				sj-=1;
    			else if(map[si][sj]=='E')
    				sj+=1;
    			else if(map[si][sj]=='S')
    				si+=1;
    			else if(map[si][sj]=='N')
    				si-=1;
    		} 
    		if(!(si>=1 && si<=n) || !(sj>=1 && sj<=m))
    			printf("%d step(s) to exit\n",step);
    		else
    		{
    			memset(dis,0,sizeof(dis));
    			while(!dis[si][sj])
    			{
    				step1++;
    				dis[si][sj]=1;
    				if(map[si][sj]=='W')
    					sj-=1;
    				else if(map[si][sj]=='E')
    					sj+=1;
    				else if(map[si][sj]=='S')
    					si+=1;
    				else if(map[si][sj]=='N')
    				si-=1;
    			}
    			step=step-step1;
    			printf("%d step(s) before a loop of %d step(s)\n",step,step1);
    		}		
    	}
    	return 0;
    }


  • 相关阅读:
    Codeforces 1105D Kilani and the Game【BFS】
    Codeforces 1096D Easy Problem 【DP】
    Codeforces 920F
    Codeforces 1076D Edge Deletion 【最短路+贪心】
    POJ 3090 Visible Lattice Points 【欧拉函数】
    POJ 1284 Primitive Roots (欧拉函数+原根)
    HDU 2841-Visible Trees 【容斥】
    HDU 1796 How many integers can you find 【容斥】
    HDU 4135 Co-prime (容斥+分解质因子)
    CodeForces 161D Distance in Tree【树形DP】
  • 原文地址:https://www.cnblogs.com/freezhan/p/2974247.html
Copyright © 2011-2022 走看看