zoukankan      html  css  js  c++  java
  • hdu 1058 Humble Numbers【丑数】

    DP&&英语==

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1058

    Humble Numbers

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9933    Accepted Submission(s): 4291


    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

    Write a program to find and print the nth element in this sequence
     

    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
     

    Output
    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
     

    Sample Input
    1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
     

    Sample Output
    The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
     

    Source
     

    典型的DP问题。

    思路:后面的丑数,必定是前面的一个丑数乘以2,3,5,7后比前一个大,而又最小的数。

    注意:英语的序数词很坑爹啊!一不小心就WA了~~~

    下面看代码:

    // AC 62ms 284k(by C++)
    #include<stdio.h>
    #include<string.h>
    int dp[5850]={0,1};
     
    int min(int a,int b,int c,int d)
    {
    	a = a<b ? a:b;
    	b = c<d ? c:d;
    	return a<b ? a : b;
    }
    
    int main()
    {
    	int n;
    	int i;
    	int x1,x2,x3,x4;
    	int dp1,dp2,dp3,dp4;
        x1=x2=x3=x4=1;
    	for(i=2;i<=5845;i++)
    	{
    		dp1=dp[x1]*2;     //后面的数必定是前面的数乘以着四个数,取其中最小的一个,即为下一个丑数。
    		dp2=dp[x2]*3;
    		dp3=dp[x3]*5;
    		dp4=dp[x4]*7;
    		dp[i]=min(dp1,dp2,dp3,dp4);
    		if(dp[i]==dp1)    x1++;     //注意不用加else , 因为有些会相等
    		if(dp[i]==dp2)    x2++;
    		if(dp[i]==dp3)    x3++;
    		if(dp[i]==dp4)    x4++;
    	}
    	while(scanf("%d",&n)!=EOF && n)
    	{
    		if(n%10==1 && n%100!=11)
    			printf("The %dst humble number is %d.\n",n,dp[n]);
    		else if(n%10==2 && n%100!=12)                            //注意要加else , 否则有些会输出两个答案
    			printf("The %dnd humble number is %d.\n",n,dp[n]);
    		else if(n%10==3 && n%100!=13)
    			printf("The %drd humble number is %d.\n",n,dp[n]);
    		else
    			printf("The %dth humble number is %d.\n",n,dp[n]);
    	}
    	return 0;
    }



  • 相关阅读:
    我和LEGO Mindstroms NXT(1)
    [翻译]介绍Xbox LIVE社区游戏
    想做一个显示全国火车运行图的网站(1)想想
    [翻译]CCR and DSS Toolkit 2008 发布了
    我和LEGO Mindstroms NXT(2)
    [翻译]机器人游戏可以下载了!
    vs的form标签引起css走样问题
    做个md5查询站(1)从8年前说开去
    [翻译]Microsoft Robotics Developer Sutdio 2008 7月CTP发布了
    做个md5查询站(3)数据格式
  • 原文地址:https://www.cnblogs.com/freezhan/p/2974250.html
Copyright © 2011-2022 走看看