zoukankan      html  css  js  c++  java
  • hdu 1316 How Many Fibs?【JAVA大数】

    How Many Fibs?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2814    Accepted Submission(s): 1112


    Problem Description
    Recall the definition of the Fibonacci numbers: 
    f1 := 1 
    f2 := 2 
    fn := fn-1 + fn-2 (n >= 3) 

    Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
     

    Input
    The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
     

    Output
    For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
     

    Sample Input
    10 100 1234567890 9876543210 0 0
     

    Sample Output
    5 4
     

    Source
     

    Recommend
    Eddy
     

    又钻了 JAVA 的空子,一下就 AC 了,

    但是奇怪的是,为什么我把内存减少一半,空间没有节省多少,时间反而多了一些

    8276754 2013-05-10 16:30:33 Accepted 1316 171MS 3704K 955 B Java free斩
    8276732 2013-05-10 16:28:32 Accepted 1316 140MS 3752K 958 B Java free斩
    import java.util.*;
    import java.math.*;
    import java.io.*;
    
    public class Main {
    	public static void main(String args[]) {
    		BigInteger []f = new BigInteger[500];
    		f[1] = new BigInteger("1");
    		f[2] = new BigInteger("2");
    		for(int i = 3; i < 500; i++) {
    			f[i] = f[i-1].add(f[i-2]);
    		}
    		/* 
    		String s = f[499].toString(); //算出有 105 位
    		int len = s.length();
    		System.out.println(len);
    		*/
    		Scanner cin = new Scanner(new BufferedInputStream(System.in));
    		BigInteger a,b;
    		BigInteger c = BigInteger.valueOf(0);
    		while(cin.hasNextBigInteger()) {
    			a = cin.nextBigInteger();
    			b = cin.nextBigInteger();
    			
    			if(a.compareTo(BigInteger.valueOf(0)) == 0 && b.compareTo(c) == 0) {
    				break;
    			}
    			
    			int ans = 0;
    			for(int i = 1; i < 500; i++) {
    				if(f[i].compareTo(b) == 1) {
    					break;
    				}
    				if(f[i].compareTo(a) >= 0 && f[i].compareTo(b) <= 0) {
    					ans++;
    				}
    			}
    			System.out.println(ans);
    		}
    	}
    }
    


  • 相关阅读:
    C/C++网络编程2——socket函数
    C/C++网络编程1——linux下实现
    nginx_2_nginx进程模型
    nginx_1_初始nginx
    C++11并发编程4------线程间共享数据
    C++11并发编程3------线程传参
    C++11并发编程2------线程管理
    C++11并发编程1------并发介绍
    打造自己的开发环境
    gcc/g++/make/cmake/makefile/cmakelists的恩恩怨怨
  • 原文地址:https://www.cnblogs.com/freezhan/p/3219058.html
Copyright © 2011-2022 走看看