zoukankan      html  css  js  c++  java
  • hdu 3038 How Many Answers Are Wrong【并查集的简单应用】

    How Many Answers Are Wrong

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1384    Accepted Submission(s): 562


    Problem Description
    TT and FF are ... friends. Uh... very very good friends -________-b

    FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

    Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

    Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

    The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

    However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

    What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

    But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
     

    Input
    Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

    Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

    You can assume that any sum of subsequence is fit in 32-bit integer.
     

    Output
    A single line with a integer denotes how many answers are wrong.
     

    Sample Input
    10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
     

    Sample Output
    1
     

    Source
     

    Recommend
    gaojie


    题意:给你 N 个数 M 条判断,要你判断出给出的 M 条判断有几条错的。

          每条判断中 X  Y  W 表示从第 X 个数一直加到第 Y 个数的总和为 W。


    算法:并查集。


    思路转换

    两种方案【本质一样】:一、想成 Y 比 X-1 大 W

                              用 r[] 记录从父亲节点一直加到当前节点的值

                              以前面的点为根

                          

                          二、想成 X 比 Y+1 少 W 也一样

                              用 r[] 记录从当前节点一直加到父亲节点的值

                              以后面的点为根

                           

    M Accepted 1408 KB 31 ms C++ 848 B 2013-04-11 18:15:35

    #include<cstdio>
    
    const int maxn = 200000+10;
    
    int p[maxn];
    int r[maxn];
    
    int find(int x)
    {
        if(x == p[x]) return x;
    
        int t = p[x];
        p[x] = find(p[x]);
        r[x] = r[x]+r[t];
    
        return p[x];
    }
    
    void Union(int x, int y, int w)
    {
        int fx = find(x);
        int fy = find(y);
    
        p[fy] = fx;
        r[fy] = -r[y]+w+r[x];
    }
    void set(int n)
    {
        for(int i = 0; i <= n; i++)
        {
            p[i] = i;
            r[i] = 0;
        }
    }
    int main()
    {
        int n, m;
        while(scanf("%d%d", &n, &m) != EOF)
        {
            set(n);
            int ans = 0;
            int x, y, w;
            while(m--)
            {
                scanf("%d%d%d", &x, &y, &w);
    
                x--;
                if(find(x) == find(y))
                {
                    if((r[y]-r[x]) != w) ans++;
                }
                else Union(x, y, w);
            }
            printf("%d\n", ans);
        }
        return 0;
    }

    M Accepted 1416 KB 31 ms C++ 897 B 2013-04-14 13:08:34

    #include<cstdio>
    
    const int maxn = 200000+10;
    
    int p[maxn];
    int r[maxn];
    
    int find(int x)
    {
        if(x == p[x]) return x;
    
        int t = p[x];
        p[x] = find(p[x]);
        r[x] = r[x]+r[t];
    
        return p[x];
    }
    
    void Union(int x, int y, int w)
    {
        int fx = find(x);
        int fy = find(y);
    
        p[fy] = fx;
        r[fy] = -r[y]+w+r[x];
    }
    void set(int n)
    {
        for(int i = 0; i <= n; i++)
        {
            p[i] = i;
            r[i] = 0;
        }
    }
    int main()
    {
        int n, m;
        while(scanf("%d%d", &n, &m) != EOF)
        {
            set(n);
            int ans = 0;
            int x, y, w;
            while(m--)
            {
                scanf("%d%d%d", &x, &y, &w);
    
                x--;
                if(find(x) == find(y))
                {
                    if((r[y]-r[x]) != w) ans++;
                }
                else Union(x, y, w);
            }
            printf("%d\n", ans);
        }
        return 0;
    }
    



  • 相关阅读:
    不相交集实现实例
    TQ2440开发板挂载U盘出现乱码
    快速选择实例
    linux2.6.30.4内核移植(7)——插入hello world驱动模块
    linux2.6.30.4内核移植(6)——移植应用程序hello world常见的错误:-bin/sh ./hello not found
    linux2.6.30.4内核移植(5)——构建根文件系统(yaffs文件系统格式的镜像)
    linux2.6.30.4内核移植(4)——完善串口驱动
    linux2.6.30.4内核移植(3)——yaffs文件系统移植
    linux2.6.30.4内核移植(2)——Nand Flash驱动移植
    快速排序实例
  • 原文地址:https://www.cnblogs.com/freezhan/p/3219074.html
Copyright © 2011-2022 走看看